AdGuard Mac Slowing down Page Loading

Discussion in 'Discussion (Beta Versions)' started by chromatinfish123, Feb 15, 2015.

  1. chromatinfish123

    chromatinfish123 Beta Tester

    Joined:
    Apr 19, 2014
    Messages:
    47
    Hi Everybody,

    I've not been active for quite a while- Adguard for Mac is still doing its job well!

    However, Adguard is slowing down page load time since installation. Sometimes a page will hang in the middle of loading. Games will also freeze and stop responding. Once I click on the Adguard button, then the Wifi button, the page will load. This only happens on non-major pages such as Numbeo, never on Google.
     
  2. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,902
    Can you please enable detailed log, reproduce the problem and send logs to us? PM me or @George those logs, please.

    EDIT: To enable detailed log, open Adguard menu, go to settings, choose 'Advanced' -> 'Logging Level' -> 'Debug'
     
    Last edited by a moderator: Feb 17, 2015
  3. saturnotaku

    saturnotaku Beta Tester

    Joined:
    Jan 9, 2015
    Messages:
    55
    I've been experiencing the same problems as well. Page loads, even on Google, become extremely slow or timeout all together. This is both on Safari and Chrome. Strangely enough, enabling debug mode seemed to have helped things. Loads were noticeably faster that way. Where does one find the detailed log to submit it?
     
  4. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,902
    You can enable detailed log in 'Settings - Advanced - Logging level - Detailed'. It would be great if you could send it to us.
     
  5. saturnotaku

    saturnotaku Beta Tester

    Joined:
    Jan 9, 2015
    Messages:
    55
    I understand that, but where does one find the log to be able to send it to you? In what folder is it located on a Mac?
     
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Path to logs directory:
    ~/Library/Logs/Adguard

    You can find our logs using "Console" app.
     
  7. saturnotaku

    saturnotaku Beta Tester

    Joined:
    Jan 9, 2015
    Messages:
    55
    Here are two log files that were created when I enabled debug mode the last time pages were loading slowly on Safari with Adguard enabled.

    Edit: The slow page loading appears to only be an issue with Safari. I've been using Chrome this evening and have experienced no problems.
     

    Attached Files:

    Last edited by a moderator: Feb 24, 2015
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    We also need to know some more things:
    1. Precise timing (when the slowdown happened)
    2. Page address