AdGuard & MS EDGE

geek

New Member
Здравствуйте!
Возникла проблема работы Adguard 6.0 в Windows 10. Проблема заключается в том что Adguard не работает в данном браузере, хотя в IE программа работает на 5+. Данная проблема наблюдается только в версии браузера Microsoft Edge 25, а вот на другом компьютере, с версией Edge 20 проблем не наблюдается. Проскочила инфа, что теперь в обновлении Edge появилась защита от dll-иньекций и еще куча разных исправлений. Кто может сказать, что теперь делать? Откатить версию браузера (как?) или ждать обновления Adguard (как долго?)?
 
Last edited by a moderator:

vasily_bagirov

Administrator
Staff member
Administrator
Здравствуйте! Самое простое, что может быть причиной - выключенный WFP драйвер в настройках Adguard. Фильтрация в Edge возможно только при включенном WFP драйвере.
 

geek

New Member
Опция "Использовать сетевой WFP-драйвер" была выключена. После ее включения, фильтрация в EDGE заработала. Появилась другая проблема, связанная с HTTPS протоколом, он либо не фильтруется (Опция "Фильтровать HTTPS протокол" выключена), либо не работает (Опция "Фильтровать HTTPS протокол" включена). Во втором случае все браузеры отвечают "Невозможно загрузить эту страницу".
....
Проблема решена! Она заключалась в антивирусе. У меня установлен Kaspersky 2016 Free. Необходимо отключить проверку защищённых соединений: Настройка -> Дополнительно -> Сеть -> Проверка защищенных соединений : Не проверять защищенные соединения

PS. Большинство проблем с сетью заключается в антивирусах!!!
 
Last edited by a moderator:

vasily_bagirov

Administrator
Staff member
Administrator
Прям нечего и добавить :) На самом деле да, проблема есть в конфликте WFP драйвера, мы о ней знаем. К сожалению, простого решения лучше, чем отключение проверки защищенных соединений в антивирусе или HTTPS фильтрации в Адгард нет. Мы работаем над созданием нового сетевого драйвера, который бы не вызывал конфликта, но это большая работа и готов он будет не раньше чем через несколько месяцев.
 
Top