AdGuard not in programs list for uninstall, cannot upgrade to new beta.

DoctorPC

Beta Tester
Strange issue. Adguard is installed, and running. But errors out when I try to upgrade to the new beta.

Adguard no longer appears as an installed program!

How do I fix these issues? I've tried reboots, clearing caches, and everything I can think of.. Highly annoying!
 

Attachments

rickyoh

Beta Tester
have you tried running Adguards uninstaller(C:\Program Files (x86)\Adguard\Uninstall Adguard Web Filter) directly ?
 

rickyoh

Beta Tester
ok, could you confirm that you have "setup.msi" in this folder: "C:\ProgramData\Update2343200959509\5.9.1069.5465" it is approximately 10 MB's and has an md5 hash of F7D7A40CDCA52DB3D393DA01C8BBE142. if it's there, run it and use either "repair" or "remove" to try to solve your issues.
if this does not work try starting the windows installer service manually in the services menu(win+r --> services.msc) and try updating Adguard.
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
have you tried running Adguards uninstaller(C:\Program Files (x86)\Adguard\Uninstall Adguard Web Filter) directly ?
Oh, it wouldn't work, we should remove it with update to 5.9.

---------- Post added at 10:35 AM ---------- Previous post was at 10:31 AM ----------

Strange issue. Adguard is installed, and running. But errors out when I try to upgrade to the new beta.

Adguard no longer appears as an installed program!

How do I fix these issues? I've tried reboots, clearing caches, and everything I can think of.. Highly annoying!
Do you see Adguard in your windows programs list?

You could try to update manually.

To do this:
1. Download http://static.adguard.com/5/beta/setup-5.9.1069.5465.msi
2. Rename it to setup.msi
3. Run "cmd.exe" as administrator
4. Change directory to one where you have placed setup.msi
5. Run command:
Code:
msiexec /i setup.msi REINSTALL=ALL REINSTALLMODE=vomus
 
Top