Adguard not working on 4G - EE Network Pixel 4 XL

ronny220

New Member
Hey everyone!
I've been trying to figure this out since I got my Pixel 4 XL and no joy.
HTTPS Filtering on and running Beta 3.3 beta 2.
On WiFi everything works perfectly but 4G its not applying cosmetic filtering and pages contain ads.
If I turn on pref.vpn.ipv6.disable everything on Chrome shows ERR_ADDRESS_UNREACHABLE
Please help!
 

ronny220

New Member
Thanks for your response!
That's worked for me, I do however seem to have another issue if you can help please.
I'm trying to whitelist expressvpnrouter.com
My home router has custom firmware for express VPN meaning I can switch locations by logging into this via the webpage above.
Now I keep seeing I'm not connected to my router, I have to turn off the adguard connection then it allows me to connect.
I've added the following but it doesn't seem to work, any suggestions?
 

Attachments

Chinaski

Support Marine
Staff member
Administrator
Moderator
@ronny220

I'd like to ask you to collect the logs.
We need to figure out why your connection is blocked when you connect to AdGuard DNS
Then let's do the following:
- AdGuard > Settings > Advanced > Logging Level > Record All.
- Reproduce your issue.
- Note the time the error occurred and let us know.
- Don't forget to return to the default logging level.
- Logs can be sent to me at PM or on k.gretskyi@adguard.com


As for the problem with access to the router.
Try accessing your router, then open the filtering log and see which element blocks the connection.
Unlock the request or send a screenshot of the filtering log.
 

Gillyguthrie

New Member
@ronny220
Hello there!
Try to set the Google DNS server, for example, any changes?
Nice.. this fixed my issue on Pixel 3 not being able to browse Internet while on mobile data. I could do Google searches, interestingly, but no other websites would load on mobile data. On WiFi, worked fine (whether at home or at the office). Only happened a few days ago, perhaps related to an Android update. Anyways, switching to Google DNS in AdGuard settings fixed my issue!
 
Top