Adguard on Samsung S21 slows down wifi

g4ngelo

New Member
The usual culprit should be the DNS filtering.
Either try different DNS providers to compare speeds, or you can use the system default DNS server.
Using the default DNS server usually solves all connectivity issues.
 

Casinca

New Member
Switched to a Samsung from Huawei, now you noticed it, i can't unsee it.
l’m losing 80% dl speed with adguard (stable 3.6.3) on:rolleyes:. Both phone have the same settings and everything's fine on the Huawei speedtest results

DNS doesn't do anythings tried off too.
I'm not really confident as i realize this issue is open since 8 months
 
Last edited:

Glassertje

New Member
I have a Samsung S21+ and via WiFi as data connection i see a difference.

Just tested a 10GB file download in firefox. Whit adguard on it was ~10 MB/s download and whit Adguard of i was getting a download over the 70MB/s, so it is not only speedtest related.
 
Last edited:

Casinca

New Member
yeah most recent Samsung phones on android 11. The lack of communications from Adguard is disturbing though. I'd happily send logs if that helps or already worked on
 

Glassertje

New Member
I also tried the latest nightly builds. Same problem. Normaly the support of Adguard is very fast, but the other topic is 8 months old.

For now i use blokkada, becourse the ads, driven me crazy. Now, if i download something whit Firefox on my s21+, it is very fast.

Hope there will be a fix. Use adguard for years.
 
I'm experiencing this issue on the latest 3.6.4 version, with my Mi Max 2 using Android 7.1. My net speed is 108-112mb, when AG is on, it drops to 30-50mb and doesn't go higher than 62mb according to speedtest.net. When it's off I get my full speed. First time I'm experiencing it and it's never happened on any previous version.
 

Vouad

New Member
I also have the same problem with my Samsung Galaxy S10, with Adguard on I lose 60% of my internet speed. I have never had this problem before, knowing that I have been using Adguard from the start.
Has anyone found a solution?
 

Casinca

New Member
I also have the same problem with my Samsung Galaxy S10, with Adguard on I lose 60% of my internet speed. I have never had this problem before, knowing that I have been using Adguard from the start.
Has anyone found a solution?
No solutions and they don't care about it anyways
 

Glassertje

New Member
Adguard support is investigating this issue. I send a log and some Speedtest as they requested. But it seems it is not easy to fix.

Maybe Android 12 will fix the problem, I have no idea. I tried other apps like blokkada, but I went back to Adguard.

I did some test and via WiFi and data connection i have around 300Mbit. That is more than enough for some apps.
 
Top