Adguard Pro (2.1.2 (173)) on iOS13 public beta 4 slows internet down a lot and often connection fails

spinedoc777

Beta Tester
I know iOS public beta 4 is not a general release yet, but I'm assuming you guys are working towards having your product compatible when it does become a full release. Just wanted to feedback that the internet on my phone (xs max) is extremely slow when the VPN is enabled. It will sometimes hang in Safari for 20 or 30 seconds before loading, and often it will just refuse to load. I can see the LTE icon flashing on and off with the VPN icon while it's trying to connect. Disabling Adguard Pro and the internet returns to normal. This happens in pretty much any app that needs internet such as safari, google voice, cloud settings, the app store, etc.

I did send a bug report from my phone, but thought some discussion would be good also.
 

Trumpsaduck

New Member
I never had that problem with beta 4 on my max. Try beta 5. Uninstall adguard pro, restart. Install beta 5, then force restart after the new beta boots. Reinstall adguard pro and set up. Pro is fast and still works great, even before the minor 2.1.2 update using DomainVoider in the privacy settings. Hell, even found a rogue Google tracker on this very website.
 
Last edited:

spinedoc777

Beta Tester
I'm only on public beta 4, only dev 5 has been released. My iphone is my daily driver so I'd be afraid of the dev releases, although pb4 is pretty buggy. I'm not sure what else it may be, I can toggle adguard on and off and reproduce the issue at will.
 

Trumpsaduck

New Member
Your public release is exactly the same as the dev release. Not a single difference where it counts, just a few settings features.
 

spinedoc777

Beta Tester
Yes but the public beta is usually more stable, that's why it's behind one version. I will most likely revert back to iOS12 as many other things are buggy and not usable at this time, only another month or 2 until release anyway.
 
Top