Adguard Pro on iOS slow or no internet at all

spinedoc777

Beta Tester
Adguard Pro for iOS seems to cut off my internet at times. I first noticed it in the News app where sometimes I couldn't connect to a story, or it would be extremely slow. But I've also noticed it for a lot of other internet using apps such as Safari, Netspeed and Find my phone. No rhyme or reason, sometimes it works and sometimes it doesn't, and I can directly correlate turning off the Adguard DNS and the internet working again full speed. This has happened over wifi as well as LTE. From what I understand the Pro version works again with the only caveat is its limitation in filters, although you guys still have a sticky up with very old and outdated information.

Any advice? I know the standard advice is to get a regular adguard subscription, but I'm disappointed that I paid for this app and it's not really being worked on as much as the subscription version.

Edit: this is on iOS 13.1.3. It seemed to run great on 13.1, but I may just not have had that installed long enough to see any issues. I'd be glad to beta test anything.

Edit: To add more info, internet connection just seems wonky with Adguard Pro enabled. For example sometimes the News app won't connect at all, other times it will only connect text/links but no graphics will render and I can see the VPN flashing in the taskbar forever. Same thing with music streaming apps, they will say no internet and that VPN will just sit there flashing forever until I toggle Adguard Pro off. Safari sometimes works but runs much more slowly than normal, other times it doesn't work with the VPN flashing. Same with the mail app.
 
Last edited:

Chinaski

Support Marine
Staff member
Administrator
Moderator
Hello!
It would be nice if you could "catch" the problem, collect the logs and send them to PM.
If you purchased AdGuard PRO from me, you can send me a confirmation of your purchase. I will give you a 6-month license key for the premium version of AdGuard.
 

spinedoc777

Beta Tester
Hello!
It would be nice if you could "catch" the problem, collect the logs and send them to PM.
If you purchased AdGuard PRO from me, you can send me a confirmation of your purchase. I will give you a 6-month license key for the premium version of AdGuard.
Thanks, I will for sure collect the logs. It's easy to replicate, it happens almost every time. On the license I have to be honest and say that's a bit disappointing as I paid for the lifetime version of Pro. I know you guys switched to a subscription model, but I'm still bummed that my lifetime license is going to be deprecated. Just food for thought from a loyal user who has purchased multiple licenses.


Also I seem to remember a post a while ago that Pro would be re-released with some of the new features, is that still in the works? Or are us Pro users out of luck?
 

mikeshyu

New Member
Yeah I’m having the same issues. On AdGuard Pro v2.1.2. iOS 13.2.2. The “VPN” connection constantly disconnects and connects without any user input. I did a screen recording. Notice the top right icon as it randomly shows the VPN connecting and disconnecting.

 

spinedoc777

Beta Tester
Yeah I’m having the same issues. On AdGuard Pro v2.1.2. iOS 13.2.2. The “VPN” connection constantly disconnects and connects without any user input. I did a screen recording. Notice the top right icon as it randomly shows the VPN connecting and disconnecting.

That’s exactly what’s happening with me. I don’t think they care much about us Pro users other than trying to get us to pay the subscription after we paid for the Pro version.
 

mikeshyu

New Member
I'd be more than happy to pay for a lifetime sub on the regular version ($12.99) if they implemented a system-wide ad block like they do on Pro, but it seems like regular Adguard only does safari blocking.

Regardless, in the meantime, I was able to find on Reddit a workaround for our issues:

Switch back to system default DNS, then under Privacy Settings add subscription and select Adguard SDN (IIRC this has the same list as adguard DNS).

Still works for system-wide blocking without the weird connect/disconnect issues that Adguard Pro has been suffering as of late. In case there's a site that's blocked that you don't want blocked, just add it to the whitelist.
 

Boo Berry

Moderator + Beta Tester
Moderator
They're going to try to bring the system-wide blocking to the non-Pro app, assuming it can pass Apple's app review.
 

spinedoc777

Beta Tester
I'd be more than happy to pay for a lifetime sub on the regular version ($12.99) if they implemented a system-wide ad block like they do on Pro, but it seems like regular Adguard only does safari blocking.

Regardless, in the meantime, I was able to find on Reddit a workaround for our issues:

Switch back to system default DNS, then under Privacy Settings add subscription and select Adguard SDN (IIRC this has the same list as adguard DNS).

Still works for system-wide blocking without the weird connect/disconnect issues that Adguard Pro has been suffering as of late. In case there's a site that's blocked that you don't want blocked, just add it to the whitelist.
Thanks for that solution, I'm going to give it a try. From what I understand the regular version needs a subscription to access some features, I don't know if the planned system wide blocking on the regular version requires the sub but I will bet it most likely does. It's a shame because I thought I had paid lifetime for the Pro version, I don't mind paying again for the regular version in all honesty, but a subscription just seems a bit greedy.

EDIT: Tried your solution but when in the privacy section adding a subscription asks for a URL (there is no dropdown list or ability to select a subscription), what did you put in that field?
 

spinedoc777

Beta Tester
I was able to figure out how to add the Adguard SDN in the privacy section, I didn't realize you could click through and see the option to add it. This seemed to work for a couple of days, but just today I again saw the constant disconnecting and VPN flashing on the taskbar on my iphone along with a very slow internet connection. Specifically I was checking my text messages and my wife had sent a couple of pictures and I noticed that they were not downloading, then I noticed the VPN flashing.

For Adguard is this something that is being looked at? I've uploaded bug reports a few times. Can we assume that you guys just don't want to invest much energy into a non subscription product?
 
Top