AdGuard Pro paid version abt VPN connection problem

kong

New Member
get trouble when enable the adguard dns (vpn) function, I followed the instruction to enable that function and then automatically add vpn in control panel, however, the vpn always disconnect and reconnect, I can't even access the internet and need to shut down that function eventually. How can I solve?
Thanks adguard developer
 

vasily_bagirov

Administrator
Staff member
Administrator
@kong
Hello!
Can you please enable it again, try to access some websites so that the problem reproduces, and then send a message to support from the app? This way we will obtain DNS logs. Make sure to mention your user ID in this thread afterwards (it will be stated in the automatic email response).
 

Klaatu

New Member
I'm new to the forum, and this may not be the right place to ask this question -- but what does AdGuard Pro's VPN actually do? The information says that it's "local"...I do use PIA.
 

vasily_bagirov

Administrator
Staff member
Administrator
@Klaatu hello and welcome to the forum!

The VPN Adguard sets up is 'fake'. It means that it is indeed 'local' in the sense that no data is being sent to any remote servers. We have to use this clunky method as it is the only way to be able to change system DNS settings on iOS.
 

Klaatu

New Member
Thank you very much for the information. I do use Private Internet Access when I need "privacy." Another question - what does changing the DNS do in AdGuard, and is that something I have to do or is it done automatically when the AdGuard "VPN" is turned on? Your help is much appreciated.
 

vasily_bagirov

Administrator
Staff member
Administrator
@Klaatu changing DNS settings is optional. You can use Adguard DNS, for example, to block ads, Adguard Family Protection to block 'adult' websites, set up any custom DNS if you'd like to etc. (the ad blocking quality Adguard DNS provides is identical to system-wide ad blocking).

If you don't need anything of it, you can just stick to the system-wide adblocking and just leave DNS settings at 'system default'.
 
Top