AdGuard Pro running excessively in background iOS 13.2.3

earthling

New Member
I’ve been having AdGuard Pro running in the background excessively since the 13.2.3 update. Regardless if the app is force closed, background refresh off or hard reset of the device. It continues to run in the background regardless of me deleting the app completely and re-installing. I’ve had to stop using it and go back to the free version as it doesn’t have this issue. Just wondering if anyone has seen this or knows how to fix it. I really would like to start using it again because I’ve never had an issue with it in the past and it only effects my device on iOS 13 and not my device on iOS 12
 
Last edited:

Chinaski

Support Marine
Staff member
Administrator
Moderator
Hello there!
AdGuard PRO cannot be removed from the background on version 13.2.
Unfortunately, for a series of reasons, we are not able to update the application and fix some of the problems that have arisen after the update.
But for all PRO version owners, we provide a 6-month license key to activate the premium features for the free version.
Send me to PM purchase confirmation and your email address. I will generate a key for you :)
 

earthling

New Member
The free version with the premium features enabled also runs continuously in the background.. Turning off the DNS filtering (VPN) makes it stop. Any ideas why the DNS filtering would cause this issue?
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
Let me get this straight.
AdGuard always works in the background, as it did on earlier versions of iOS. It does its job - it filters DNS queries.
The only difference is that after the update, the background work started to appear in the system statistics.
It does not affect the battery consumption in any way.
 
Top