Adguard turns off by itself

Discussion in 'Technical Support (AdGuard for Android)' started by Misteurz, Dec 18, 2018.

  1. Misteurz

    Misteurz New Member

    Joined:
    Dec 18, 2018
    Messages:
    3
    Hi,
    I'm using adguard on my android devices for 1 or 2 years.

    Now, I have a oneplus 6 under android pie, and every day, randomly, I see ads in my apps or in my browser.

    When I check, I see that adguard is off. I have to put it on again and ads desappear.
    Do you know what to do to resolve that?
    Thanks in advance
     
  2. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,561
    Please try to install latest AdGuard Nightly version (in settings change update channel to nightly) and check again.
     
  3. Misteurz

    Misteurz New Member

    Joined:
    Dec 18, 2018
    Messages:
    3
    Ok I try.
    I'll tell you later if it works. Thanks
     
  4. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @Misteurz

    Hello!

    Seems like OxygenOS is "killing" the processes. For now, we have a special article in our KB. Please, follow the steps described and check if it helps to solve your issue.
     
  5. xalarios

    xalarios New Member

    Joined:
    Dec 22, 2018
    Messages:
    1
    I have also the same problem with Adguard v2.12.247.... disconnects after a while on Honor 7A stock Oreo Android although I have excluded it from battery optimization. I have default settings, no HTTPS filtering, only using Adguard Falily DNS. Also tried this for Huawei devices ( https://kb.adguard.com/en/android/solving-problems/background-work) with no luck. Any help about it?
     
  6. Misteurz

    Misteurz New Member

    Joined:
    Dec 18, 2018
    Messages:
    3

    Hi,
    I've done what is said ithe the special article.
    It works for me.
    Thanks!
     
  7. Lawbreaker

    Lawbreaker New Member

    Joined:
    Dec 22, 2018
    Messages:
    1
    Same thing happening to me on the latest nightly build.
    I'm using AdGuard Pro on Android 7.1.1
    It started yesterday and I don't know what could be a problem and how I could solve it. Before that, it was working perfectly. I would also like to mention that I was using nightly builds since purchasing a lifetime licence one month ago.
     
  8. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @xalarios @Lawbreaker

    Hello!

    If you did try the solution from the article and it doesn't help you - check if you did not change the priority to low for AdGuard (for example, in AdGuard - Settings - Notification settings), note that your system can decide to choose what application should be "killed" from background if it's priority is set to low.
     
  9. Absent

    Absent New Member

    Joined:
    Dec 26, 2018
    Messages:
    1
    Just updated my 5T to Pie and having the same issue with Adguard Pro, instructions on here didn't solve the issue.
     
  10. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @Absent

    Can you send the log files to support team so I can check what's wrong?

    After a disconnect - AdGuard - Send feedback.
     
  11. agreenbhm

    agreenbhm New Member

    Joined:
    Dec 29, 2018
    Messages:
    2
    This is the feedback report I just submitted. I'm using the latest nightly build on a Oneplus 6T running Pie.
    ---
    Adguard keeps stopping on the Oneplus 6T. I have followed the instructions in the knowledge base about how to prevent the service from being killed and also enabled the watchdog service, but it keeps happening. There is no option on this phone to pin apps in the background. My previous Oneplus 3T did have this option, but the 6T running Android 9 does not, so I am unable to try that suggestion.
     
  12. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @agreenbhm

    Then try to find battery saving mode / Optimizer options - add AdGuard to the exceptions.
     
  13. agreenbhm

    agreenbhm New Member

    Joined:
    Dec 29, 2018
    Messages:
    2
    As mentioned, I have already done the KB suggestions, which include that. However, I realized the phone DOES have a lock app button, but it was missing on my setup due to a tweak I made to the way Recents functions. I undid my modification and can now lock apps, so I will try that and see if it has any impact.
     
  14. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @agreenbhm

    That's interesting, keep me in touch, please.
     
  15. Learner

    Learner New Member

    Joined:
    Nov 17, 2017
    Messages:
    9
    Hello
    Just to let you know: I had the problem on my O5T since Android 9 with latest nightlies.
    I followed the tutorial (don't optimize+lock app) 3 hours ago and I the don't have the problem anymore.
     
  16. Gagome

    Gagome New Member

    Joined:
    Jan 6, 2019
    Messages:
    5
    Hello,
    I have the same problem that Adguard crashes or is ended by Android after I upgraded to Android Pie on my Nokia 8. Nokia 8 has stock Android but the solution suggested here (https://kb.adguard.com/en/android/solving-problems/background-work#Google) doesn't help. I now get the notification "Disconnected from always-on VPN" when Adguard is ended.
    And I have turned Battery Optimization off for Adguard. But this doesn't help. Then I have configured the Watchdog and have set 60 seconds then 10 seconds for the Watchdog timer but again this doesn't help. Adguard stops after some time.
    Then I have upgraded Adguard to the latest nightly build (version 3.0.166) and again this doesn't help. I have now got a new version with a new interface and several new options but it still ends itself (or is ended by Android).
    I seriously regret upgrading to Android Pie. It looks like Google has made significant changes to kill any background task when it uses battery.

    Is there anything I can do?
    Any idea?
     
  17. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @Gagome

    Hello!

    Did you change the app's notification settings? It can be closed for example, if a notification priority is set to low.
     
  18. Gagome

    Gagome New Member

    Joined:
    Jan 6, 2019
    Messages:
    5
    I have not changed anything in the notification settings for Adguard.
    There is no way to set any priority there.
    All notifications are enabled for Adguard.
     
  19. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,261
    @Gagome

    AdGuard - Settings - Advanced - Low-level settings - pref.vpn.disable.reconfigure/pause - enabled?
     
  20. Gagome

    Gagome New Member

    Joined:
    Jan 6, 2019
    Messages:
    5
    Yes, both settings are enabled.

    I have done now the following:

    Uninstalled Adguard. I did this because I wanted to go back to version 2. In version 3 the adblock killer from https://derstandard.at was not blocked by Adguard.
    Then I downloaded Adguard version 2 from your web site and installed it.
    I had to do the whole setup again because I had not saved the previous config.
    But Adguard was still ended several times during the day although I have done the VPN always on setup in Android.

    Then I tried something new:
    I swiped down to display all current notification on my phone.
    I moved the Adguard notification slightly to the right. A gear icon does show up on the left of the notification.
    I clicked this gear icon and selected "Keep showing" to the notification.
    After I did that Adguard stayed active for the whole day. I don't know if my doing has any effect.

    Probably not because Adguard was ended after I checked the low level settings pref.vpn.

    Should I disable the pref.vpn settings?