Adguard/VMware Incompatibility ?

Discussion in 'Quality Control' started by rickyoh, Feb 9, 2012.

  1. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    565
    System is a windows 7 ultimate 64 bit install, VMware workstation 8.0.2 build-591240 and the latest Adguard beta. When trying to launch VMware, the error message shown in the attached file pops up so one cannot run VMware. Interestingly this only happens when the traffic interception module in Adguard is enabled/installed, when that module is disabled in the settings VMware works without any problem.

    View attachment 145
     
  2. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Bug#876 has been created.

    Are you trying to launch VMWare application or virtual machine in it?

    You can use VMWare Player as a workaround until we fix it.
     
  3. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    565
    Error occurs when trying to launch the VMware application itself, the same error also occurs when you try to launch VMware player as well.
     
  4. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Have you tried to reinstall VMWare?

    We cannot reproduce the error on newly installed windows, so maybe the problem is not in vmware itself.
    Could you please post your system info (windows, antivirus/firewall name and version, other network-related software, etc)?
     
  5. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    565
    I have tried reinstalling VMware and still have the same problem.

    my system

    windows 7 ultimate 64 bit
    kaspersky internet security 2012

    another problem with vmware is with internet access in the virtual machine. when you turn the traffic inspection module back on when the virtual machine is up, the internet connection in the virtual machine ceases to work. but when you turn it back off the internet works again.
    i'll look into my system as well and determine if it is a conflict on the local machine.
     
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Thank you, we will test Adguard+Kaspersky+VMWare configuration.
     
  7. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    565
    thanks for looking into this