Adguard Will Not Run After Pausing

edbro

New Member
When I pause Adguard in Safari using the assistant, I am usually unable to get Adguard working again. When I press the button to pause it will then report that Adguard is not running. Or sometimes it will pause but Adguard will stop when I go to resume. Then when I press the button to start Adguard it will not.

Mac Big Sur 11.1
Adguard 2.5.1.928 release (CL-1.7.150)
 

oldsarge

New Member
If you are talking about pausing for 30 seconds on a particular site, simply go to another site and AG will be up and running. That is how it works for me.
 

edbro

New Member
No, I'm talking about selecting "Pause Adguard" at the bottom of the assistant dialog. when I select that the dialog will initially say Adguard Is Not Running and then after a few seconds will change to "Adguard Protection is Paused" with an Enable button below that. When I select Enable I get the spinning wait wheel for a few seconds and then right back to "Adguard Protection is Paused". After selecting Enable a few times it will then tell me "Adguard is not Running"
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Hello there!

Now I tried to reproduce your issue.
And the only thing I noticed was that you can't turn on the protection too quickly after it has been turned off.
You have to wait a few seconds for the AdGuard assistant to tell you that the protection is paused.
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
After several attempts I finally able to reproduce the issue.
Thanks for the report.
Here is a link to GitHub, where you can track the solution to the issue.
 

RichN

New Member
Yeah, I've been having the exact same issue. I've even removed Adguard from my system because of it, because I found this bug very annoying. A good opportunity to try some other adblockers. Guess what, I still prefer Adguard. So I'll be watching the GitHub thread and will re-install Adguard as soon as the issue is resolved. Glad that the bug was acknowledged.
 

thomasrussell

New Member
This is what I came on to report. Pausing on a site, pauses adguard for all sites and can not be turned back on. I've been fighting with adguard since Big Sur.
Resetting adguard or deleting it and it's supporting files all together results in the same outcome.
 
Top