AdGuards IPv6 DNS doesn’t work properly on my WiFi?

SergZZZ

New Member
Here is my problem. I am trying to switch my AdGuard App on my iOS 11 to use IPV6 DNS AdGuard servers. On cellular connection IPV6 DNS AdGuard servers work perfectly, but not on my WiFi. I have to switch back to IPV4 DNS AdGuard servers to keep blocking ads.


I am assuming I have to change settings on my WiFi router for it to work?

I have Apple Time Capsule router and IPv6 is enabled and configured to automatic with native mode I also have IPv6 connection sharing enabled but my time capsule configured to use IPv4 OpenDNS servers for content filtering.


Any one know what I should tweak to make my AdGuard IPv6 DNS to work properly on my WiFi?
 

SergZZZ

New Member
I got it to work through tunneling. My ISP claims that they support IPv6, but I am seeeing IPv6 Relay Error on my timecapsule. I don't like this workaround. So there is no way to make IPV6 DNS AdGuard servers in my AdGuard App to play nice with my home network?

The only reason why I am concerned is because my cellular T-Mobile is IPv6 and my home network is IPv4 so I have to keep jumping between one or the other for AdGuard to keep working.
 
Last edited:

SergZZZ

New Member
I solved the problem and I have solution!
It is so simple :rolleyes:

I created a DNS profile and put IPv4 and IPv6 servers in the same DNS profile and it worked.

On website it states one or the other & that’s where I got confused. I never thought combining them would work. Adguard is smart and will decide depending on which network you’re on.

For those of you who jump between cellular IPv6 networks and native WiFi IPv4 network this solution will work perfectly!
 

Anton Dm

New Member
Genius and thanks! I can confirm your setup works (Tmobile user myself) for the iPhone X. This also works across other apps e.g. Chrome for iOS
 
Top