AG VPN on Android - disconnects multiple times per day

AnthonyB

Beta Tester
I'm using AG VPN for Android v1.0.131 (SOCKS proxy mode) and AG for Android v3.4.120 on a Samsung Galaxy S10+ running Android 10 (not rooted).
I am working from home so 99% of the time my phone is connected to WiFi as well as 4G LTE.
I am connecting to the Sydney VPN location. I could try others but the latency is always over 10x worse for the 2nd fastest on the list.

I find 2-3 times per day that AG VPN has disconnected, which given the way things are configured, essentially stops my data connection resulting in me missing notifications from messaging apps, calendar, 2FA apps, etc.

I've just turned the log level up to trace so I potentially have something useful to review when I next observe this.

Anything else I could/should be doing or any thoughts on this issue?
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
Hello there!

In this case, we will not be able to figure it out without log archives.

Then let’s do the following (AdGuard Main App):
- AdGuard > Settings > Advanced > Logging Level > Record All.
For AdGuard VPN:
- AdGuard VPN > Advanced Settings > Export logs and system info.

- Catch your issue.
- Note the time the error occurred and let us know.
- Don’t forget to return to the default logging level.
- Logs can be sent to me at PM or on devteam@adguard.com
 

AnthonyB

Beta Tester
Thanks for that. I also noticed an app update to AG VPN for Android v1.0.136 today so will re-check if the issue is occurring.
Also just a quick note that I'm treating this differently to another issue I saw raised on Github about the app not having an auto-start on phone start option
 

AnthonyB

Beta Tester
Hello there!

In this case, we will not be able to figure it out without log archives.

Then let’s do the following (AdGuard Main App):
- AdGuard > Settings > Advanced > Logging Level > Record All.
For AdGuard VPN:
- AdGuard VPN > Advanced Settings > Export logs and system info.

- Catch your issue.
- Note the time the error occurred and let us know.
- Don’t forget to return to the default logging level.
- Logs can be sent to me at PM or on devteam@adguard.com
I'm just PM'ing you some logs.
This problem is impossible for me to pinpoint the time is occurs because I'm not looking at my phone constantly to watch if VPN disconnects. At best I could give you a vague 'in the 4 hours between timeX and timeY'.

On a related note, I've already suggested this via in-app feedback, but it baffles me that there isn't:
  1. Auto-start on phone boot
  2. A watchdog timer, like in AG, that can reconnect if it wasn't manually disconnected in X seconds.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@AnthonyB Hello again!

I received your logs, info passed to the developers.
I'll let you know as soon as they give me the necessary recommendations.
 

AnthonyB

Beta Tester
Thanks @Chinaski !

Actually, something just occurred to me.

I walk from my office to my kitchen maybe a half dozen times each working day. As a result, my phone gets passed from one WiFi AP to another AP (mesh system, all same SSID). Sometimes my phone doesn't always reliably re-connect (yay Samsung..) to WiFi. Now, my data connection is always still there, but I wonder if AGVPN isn't handling the network changes 'neatly' and as a result disconnecting?

Again, if there was a watchdog timer type of functionality to detect disconnects and trigger a reconnect after X seconds, this wouldn't be a problem :)

Oh, and autostart on phone boot (again) :)
 
Top