AGPro 2.1.2(173) + IOS 12.4.1 Cellular data failure

fotizimo

New Member
Hello,

I just recently purchased Adguard Pro for my XR device running 12.4.1 and am finding I am unable to use the product when I transition from wifi over to cellular data networks. At present, when I do transistion to the cellular networks, I have a full failure to receive any traffic on the cellular network. I have confirmed through the Adguard Pro status section that when on cellular data networks, that the application is seeing the DNS requests for the traffic I am looking to use, but I do not get any traffic back. I have tried adding and removing all sorts of filters, blacklists as well as the various DNS options, including system default, and nothing seems to have any affect on the traffic outside of turning the protection off completely. Once back on wifi, the application seems to work without any issues.

I am not sure what troubleshooting steps or options there are for this product, so thought I would start here and see what options I might have.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@fotizimo
Hello there!
The situation is repeated if you choose a different DNS server?
If the problem is not solved-please send the log file to me in PM.
 

fotizimo

New Member
Hey there,

So I was realLY starting to get some mixed results, such as the system working on cellular but not wifi, and not seeing the DNS results I was expecting, so I uninstalled the app, and restarted the device. Left it working without any adguard for a bit, then re-installed the app and rebooted. At the moment, I only have the system defaults DNS option, and the default Adguard SDN filter, as well as a Steven Black hosts file as well, and things seem to be working. I have not set any Safari filters, and am only testing in Firefox without their built-in ad protection system in place, and things seem to be working in the various apps, and while I transition between wifi and cellular data.

I will follow up in a few days and let you know what I have found.
 
Top