AIM Problem when adding facebook/GoogleTalk (Hangout)

steve1209

Beta Tester
Hi All,

I know Adguard 5.9 is not known to work yet with AIM but it has been taking care of AD's, today I added Facebook connection & Google Talk (Hangout) to AIM and when AIM started tonight I got this error on Lifestream AIM, http://screencast.com/t/lVFaNXL9b4G Guess I need to wait for V6
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Eeep, yeah. There's two possible workarounds for this; 1) You can try disabling the Adguard Assistant and this *may* go away or 2) you can try adding this rule to your user filter but it has the potential to break ad blocking in AIM, not sure (it *shouldn't*)...

Code:
@@||aolcdn.com$jsinject
This should disable script injection on that domain meaning the Assistant won't be injected. Hopefully it doesn't also interfere with blocking the ads, but I'm thinking it *shouldn't*. Also encountering this actually brings up an interesting idea too regarding the Assistant/userscripts and non-browser applications.

EDIT: Post edited, rule refined!
 
Last edited by a moderator:

steve1209

Beta Tester
Hi Boo Berry,

I'm 100% NEW here BUT thank you so much for your help, so I think I did what you requested the error remains the same is this correct? http://screencast.com/t/QndVlT3yimd6 *IF* it's correct the error is exactly the same...I don't know how to disable adguard assistant! I don't know how to remove one variable at a time as you suggested either
 

Boo Berry

Moderator + Beta Tester
Moderator
You need to double click on an empty line (below the last filter if there's any listed) of the user filters to add a new one. Try the refined rule I posted above. Hopefully Adguard v6 has add/remove/edit buttons so maintaining user filters are easier. :)
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Like this. That bar where you're placing the rule is just the search bar - it doesn't add/remove/edit any filter rules. Just double click on the empty line with a checkbox to edit it (paste the rule in) then press enter. The area below the rule in the screenshot with the unchecked box is the empty line mentioned.

 
Last edited by a moderator:

steve1209

Beta Tester
Hi Boo Berry,

Thanks much for the help, I got it installed and it seems to be working on AIM now, here is my user filter now screenshot

Somehow I got another rule in User Filter, I unchecked enabled, it there a way to deleted unwanted user filter entries?
 

Nameless

Beta Tester
left click unwanted filter and choose "Delete the rule" or select the filter and press "Del" on your keyboard
 

Boo Berry

Moderator + Beta Tester
Moderator
Okay, let's try this - make sure AIM is exited. If you can delete that existing rule, do so, and add this as a new rule. Keep in mind there's a chance this new rule could break blocking of ads if AIM uses aolcdn.com as a ads domain.

Code:
aolcdn.com$elemhide,content,urlblock,jsinject
After that, start AIM up and try again. If it doesn't work, it could be considered an incompatibility which will have to be addressed in v6 when applications (and application-specific rules) are supported officially.
 

steve1209

Beta Tester
Hi Boo Berry,

Exited AIM, removed old user filter, installed your new proposed filter, same problem, here is the new filter installed screenshot BTW the Ad's are still being removed just fine! Again, thank you for the help!
 

Boo Berry

Moderator + Beta Tester
Moderator
Whoops, messed that filter up (shouldn't make 'em when half-asleep!). :p Here's the proper one...

Code:
@@||aolcdn.com$elemhide,content,urlblock,jsinject
 

steve1209

Beta Tester
Hey Boo Berry,

The NEW user filter works and AIM Ad's are still removed, wow Thanks so much for keep working on this problem, I REALLY appreciate it!!
 
Top