[Android 2.7.153] Connection issues thanks to AdGuard

randomusername

Beta Tester
I bought an LG G5 a couple of weeks ago, using stock Android 6.0.1 (no root) with the latest Adguard beta. (By the way: My key runs out soon... do you read this or do you need a new PM? :p)

Every few days, when connected on APN (WiFi doesn't have any issue), my network gets horribly slow even on LTE, most services (including Threema) lose their connection. Disconnecting and reconnecting the Adguard VPN fixes the issue.

Can I help to fix this?
 

avatar

Administrator
Staff member
Administrator
By the way: My key runs out soon... do you read this or do you need a new PM?
@vasily_bagirov please take a look.

Every few days, when connected on APN (WiFi doesn't have any issue), my network gets horribly slow even on LTE, most services (including Threema) lose their connection. Disconnecting and reconnecting the Adguard VPN fixes the issue.
I'll need a log captured with "record everything" level.
 

avatar

Administrator
Staff member
Administrator
On second thought, I think default log may be enough. Could you please get all the log files from AG cache?
 

randomusername

Beta Tester
Sure. Attached is today's log. :)

(Random side note: I'm in the WiFi now. I enabled Adguard again and set the log level to "Log everything" - then my whole device's WiFi went off. I don't know if there's a relation or I just accidentally pressed a button. This was right before creating this log.)
 

Attachments

avatar

Administrator
Staff member
Administrator
@randomusername when was the last time you faced that problem?

I see a few weird errors in yesterdays log:
18:55:32.642 [Thread-33033] ERROR com.adguard.android.filtering.vpn.e - TUN: Error while writing to the tun device
19:54:26.287 [Thread-33033] ERROR com.adguard.android.filtering.vpn.e - TUN: Error while writing to the tun device

Is that it?
 

randomusername

Beta Tester
OK, I noticed that it also happens on WiFi now. I enabled the full log, then I went to sleep around 1:15 am, when I woke up on 8:20 am, Adguard had frozen the connection again. I shut down the VPN and made a copy of the Adguard log then. Here it is.
 

Attachments

avatar

Administrator
Staff member
Administrator
OK, I noticed that it also happens on WiFi now. I enabled the full log, then I went to sleep around 1:15 am, when I woke up on 8:20 am, Adguard had frozen the connection again. I shut down the VPN and made a copy of the Adguard log then. Here it is.
Yep, it definitely seems to be caused by that ENOBUFS error.

Filed a bug report on this:
https://github.com/AdguardTeam/AdguardForAndroid/issues/734

I see that just before this error occurred Android was downloading something (maybe an update or something like that?).
Also I see that there were several downloads at the same time. Download speed was about 1-1.5 MByte/sec.

I suppose that if you turn Adguard off for "Download Manager" (apps & statistics -> download manager -> uncheck "enabled" there) it will solve this issue at least temporary.
 

avatar

Administrator
Staff member
Administrator
@randomusername hi! It took quite some time, sorry for this.

The next beta version (should be out tomorrow) should resolve this issue. Could you please try it when it is out?
 
Top