[Android 8.1] [Resolved] Always-on VPN breaks Adguard start on boot

Cool_Nick_Name

Beta Tester
I'm not exactly sure what the Always-on option in the VPN settings does, but when I activate it and restart my device it gives me a message saying my always-on VPN Adguard is disabled, so I have to manually start it in the app.

With the setting turned off Adguard starts on boot normally.


I'm trying to find an alternative to the permanent Adguard notification in my notification tray, because when I try to disable it I get warned that the Adguard process might be stopped at any time if the message is disabled.
This always-on option seems like the perfect way to go, so if this gets resolved you might want to add to that warning popup a message telling about this alternative method.
 

avatar

Administrator
Staff member
Administrator
The current release version of AG is not fully compatible with always-on VPN.

But I've got some good news for you -- today's nightly is supposed to resolve this issue:)
 

Cool_Nick_Name

Beta Tester
The current release version of AG is not fully compatible with always-on VPN.

But I've got some good news for you -- today's nightly is supposed to resolve this issue:)
Great! And to update to the nightly I just need to update on the beta channel?

Edit: I see there's a nightly channel too . Out of curiosity, since I'm a beta tester after all, do you think I should leave my update channel on nightly?
 

avatar

Administrator
Staff member
Administrator
Edit: I see there's a nightly channel too . Out of curiosity, since I'm a beta tester after all, do you think I should leave my update channel on nightly?
It's up to you:) Nightly might be quite unstable, just keep it in mind if you decide to switch.
 
Top