Android N, Gmail not working when AdGuard is enabled

Discussion in 'Technical Support (AdGuard for Android)' started by Yogesh, May 29, 2016.

Tags:
  1. Yogesh

    Yogesh New Member

    Joined:
    May 28, 2016
    Messages:
    2
    Hello,

    I have been using Adguard premium for about six months now and have been very satisfied with the application's performance.

    Recently I upgraded to Android N Beta. Everything works fine except the Gmail app which completely fails to download any attachments. As soon as I click on the attachment, it shows the "Fetching attachment" popup and just stays there forever, stuck at 0%. I tried almost everything:

    • Removing all updates of Gmail.
    • Reinstalling the updates.
    • Checked Gmail's permissions (which are all set i.e. Contacts, Calendar and Storage)
    • Tried resetting Download Manager's data and cache.
    • Tried resetting MTP Host's data and cache.
    • Checked if the Gmail app or Download Manager is disallowed in the firewall settings of Adguard. It wasn't.
    The only way to make the download work is by disabling Adguard. As soon as I disable it, the download works perfectly.

    I don't see this problem happening elsewhere except Gmail with one exception, which I am not sure is connected or not. Today I tried updating Adguard to version 2.5.196 from the Android app itself (to check if the updated app might fix the Gmail issue, which as you might understand from this post, didn't), and it also got stuck on the downloading popup for a long time. I uninstalled Adguard and reinstalled it.

    Please look into this issue as Gmail is very important to me and I don't want to stop using Adguard also.

    Thanks & Regards,
    Yogesh.
     
  2. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    Hi!

    So you're now on AG version 2.1?

    We've got some similar complaints recently, all have in common the issue with the downloads manager and Android N.

    Some things to try:
    1. Try turning off ad blocking for the Gmail app (you can do it in the firewall section).
    2. Try adding gmail or downloads app to network exceptions: go to settings - advanced - low level settings - tap on pref.net.exclusions and add app package name to that list.
     
  3. Yogesh

    Yogesh New Member

    Joined:
    May 28, 2016
    Messages:
    2
    I'm on version 2.5.196.

    And thanks for the suggestion. It solved the problem.

    For anybody else looking to solve the issue, as avatar suggested, add com.google.android.gm to pref.net.exclusions.