Android - Problems with local proxy and VPN modes

Discussion in 'Technical Support (AdGuard for Android)' started by ZupaDee, Jan 11, 2019.

  1. ZupaDee

    ZupaDee New Member

    Joined:
    Dec 22, 2018
    Messages:
    4
    My phone info: Samsung S8+, Android 8.0.0, Rooted
    I'm using latest nightly beta version of AdGuard (Premium; although latest stable has same issues) and when connected to Wi-Fi and in local proxy mode Google Play Store won't update apps at all. When I switch to VPN mode, updates proceed as normal. More interestingly this is happening only when I'm connected to Wi-Fi (even if I disable all possible firewalls/protections in my router towards my phone). Mobile data hasn't got this problem.
    Additionally in local proxy mode Signal app will accept incoming messages, but no images can be downloaded. This problem also doesn't happen in VPN mode.

    On the other hand when using VPN mode AquaMail app cannot establish communication with mailbox.org.

    Any ideas how to solve mentioned issues? Thanks.
     
    Last edited: Jan 11, 2019
  2. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,418
    @ZupaDee

    Hello!

    It's about root proxy mode or manual mode?
     
  3. ZupaDee

    ZupaDee New Member

    Joined:
    Dec 22, 2018
    Messages:
    4
    Sorry, forgot to mention my phone is rooted.
     
  4. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,418
    @ZupaDee

    Can you try to reproduce this issue and check what's happening in the filtering log? (Also, check with disabled DNS filtration).
     
  5. ZupaDee

    ZupaDee New Member

    Joined:
    Dec 22, 2018
    Messages:
    4
    Got the log. Since I never had a look at it I haven't noticed anything special but I'm no expert.
    Anyway even with DNS filter disabled, local proxy and Wi-Fi Google Play doesn't update and AquaMail still reports error.
    Is there a way to submit my log without posting it here?
     
  6. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,418
    @ZupaDee

    Sure, you can send it to me in direct messages or send feedback to our support team at support@adguard.com.

    For now on, disable filtration for Aquamail and Google Play (AdGuard - Apps management - Aquamail/Google Play)
     
  7. ZupaDee

    ZupaDee New Member

    Joined:
    Dec 22, 2018
    Messages:
    4
    Since I've disabled filtering on both apps problems are gone. Do you stil need me to submit logs?