Apply the rule to all websites not working?

Discussion in 'Technical Support (AdGuard for Windows)' started by Bushido, May 1, 2017.

  1. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
    Hi,

    after I have enabled ,,Apply the rule to all websites" in Adguard Assistant and clicked ,,Block", then ad reappears after refresh of a web-page.
    After I just click ,,Block", then ad disappears completely.
    Is this normal or am I not understanding the,,Apply the rule to all websites" function?
     
  2. Blaz

    Blaz Moderator & Translator Moderator

    Joined:
    Dec 21, 2014
    Messages:
    7,612
    Has the site you are referring to a genericblock exclusion in filtering log?
     
  3. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
    What is a genericblock exclusion? I have this behaviour in all websites.
     
  4. Blaz

    Blaz Moderator & Translator Moderator

    Joined:
    Dec 21, 2014
    Messages:
    7,612
    @@||test.com^$genericblock

    That is a genericblock exclusion.
     
  5. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,188
    @Bushido
    I tried this for two random websites and couldn't achieve the same result as you. Please provide 2-3 specific examples of websites and elements to block to reproduce this problem.
     
  6. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
  7. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,188
    @Bushido
    hm, for example, for the blue bar on forum.adguard.com, does the rule you create look like this?
    Code:
    ##footer:nth-child(3)
    For me it does, and refreshing the page doesn't make the bar appear again.
     
  8. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
    @vasily_bagirov
    Assistant creates this rule:
    Code:
    ##footer:nth-child(2) > div.footer > div.pageWidth > div.pageContent
    During preview window, it disappears but after refreshing the page, it appears again.
     
  9. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,188
    @Bushido Assistant doesn't always create the ideal rule, you can try to move the slider to achieve a better result.
     
  10. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
    I have tried to move the slider but still no luck. ,,Apply the rule to all websites" has been working before but now it is not :/
     
  11. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,188
    @Bushido I'm lost, what version of Assistant do you have?
     
  12. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
  13. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,188
    @Bushido please record a short video of the problem. Otherwise, we will be shooting in the dark for a long time.
     
  14. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119
    @vasily_bagirov Can we make a TeamViewer session? Recording a video is not convenient for me.
     
  15. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,188
    @Bushido sure, but it's either today or after the June 11th - Im going to be on vacation these days. Please PM me or send a Skype message.
     
  16. Bushido

    Bushido Member

    Joined:
    May 15, 2016
    Messages:
    119