Automatic configuration script - Proxy

Blaz

Moderator & Translator
Staff member
Moderator
Also error. Due to internal information guidelines I am not allowed to share the proxy script (it simply just checks the hostname and then either redirect to a proxy address or return DIRECT which is the case for my computer name). You don't have to investigate any more as it is probably blocked on proxy script. Thanks for your efforts avatar.

Dolfi, of course the admin restricts things as he should be for security, but Adguard is not a vicious tool. Of course admin can set it up as he wants the security. There are always ways to circumvent, but I am not gonna to.
 

avatar

Administrator
Staff member
Administrator
Also error. Due to internal information guidelines I am not allowed to share the proxy script (it simply just checks the hostname and then either redirect to a proxy address or return DIRECT which is the case for my computer name). You don't have to investigate any more as it is probably blocked on proxy script. Thanks for your efforts avatar.
Looks like you'll have this issue with all .NET framework apps.

Check your PAC mime-type, should be "Content-type: application/x-ns-proxy-autoconfig"
 

Blaz

Moderator & Translator
Staff member
Moderator
Yes, when putting the proxy address script into the browser, the download field in FireFox says "application/x-ns-proxy-autoconfig"
 

Blaz

Moderator & Translator
Staff member
Moderator
Proxy address which is determined looks OK, but program still has ERROR.

EDIT: Putting that proxy address manually into Adguard and then adding my domain credentials, it could connect and get updates, thank you :)

Is it possible to implement a feature, so Adguard is reading the domain login credentials and is first trying it for proxy?
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Proxy address which is determined looks OK, but program still has ERROR.

EDIT: Putting that proxy address manually into Adguard and then adding my domain credentials, it could connect and get updates, thank you :)

Is it possible to implement a feature, so Adguard is reading the domain login credentials and is first trying it for proxy?
Strange thing because it should use domain credentials automatically (I mean Adguard should).

Test app didn't do it. I've updated it once again:
https://www.dropbox.com/s/awwgcd5czthlfen/ProxyTestApp.exe?dl=0
 

Blaz

Moderator & Translator
Staff member
Moderator
ERROR again :(
Is it having a problem as I'm logged in via PKI (smartcard), so it isn't reading the normal AD credentials?
 
Top