BETA crashing right when initializing

Dolfi

Banned
Hi,

installed todays BETA (no UI == no version displayable :(, exe has file version 5.10.1178.6114) on a fresh machine (AG never installed).
After install 'Preparation for program launch' runs and makes AdGuardSvc crash* (before language selection). Manually restarted svc, clicked [connect] in AG UI, same again.

Uninstalled, installed 5.10.1167.5997 and startup (incl. 'Preparation for program launch') worked well.

Uninstalled (leaving settings on system), installed BETA again, crash again.


P.S. Please make version etc copy&pastable from UIs about tab! It's really unnecessary to have to type them manually.

*I saved a crashdump (18MB) in case you're interested? Just won't upload it publicly.
 
Last edited by a moderator:

Dolfi

Banned
Dear Andrey,

it's a very bad idea to have Google as MX.
You know how curious they are and that they almost never forget (just like NSA). Sending a crash log by mail to Google is nearly as bad as uploading it to a public FTP site.

I was glad you found/created a more customer/privacy friendly option.

Thx, Dolfi
(sent the dump anyway as this is just an empty test machine but would not send logs of my productive machines to such an account).
 

avatar

Administrator
Staff member
Administrator
Looks like we need Adguard log file also (%programdata%\Adguard\Logs\service).

Source exception should be somewhere there.
 

Dolfi

Banned
will send, most probably the relevant part'll be:

Code:
ERROR, AdguardSvc, 3, 09.12.2014 14:10:39.257, Error starting filtering service: System.DllNotFoundException: Unable to load DLL 'nfapi': The specified procedure could not be found. (Exception from HRESULT: 0x8007007F)
Source: Adguard.Network
Stack trace:    at Adguard.Network.NetFilter.NFAPI.nf_setOptions(UInt32 nThreads, UInt32 flags)
   at Adguard.Network.DriverApi.Init(PFEventsDefault eventHandler, FilteringConfiguration configuration)
   at Adguard.Network.DriverApi.Start(FilteringConfiguration configuration)
   at KA9XQi7WmYo7cTPrA2.aZiR9OUm2liJTMF1YA.QDLEXrmSFjNIXRuv3hf(Object )
   at KA9XQi7WmYo7cTPrA2.aZiR9OUm2liJTMF1YA.YyWghprfl1(NetworkConfiguration )
   at KA9XQi7WmYo7cTPrA2.aZiR9OUm2liJTMF1YA.H4kgmkExJW()
 

avatar

Administrator
Staff member
Administrator
Second one is also relevant (and weird):
Code:
System.IO.FileNotFoundException: Could not load file or assembly 'Adguard.Html, Version=5.10.1178.6114, Culture=neutral, PublicKeyToken=cc321ba03e90d705' or one of its dependencies. The system cannot find the file specified.
Source: Adguard.Filter
Stack trace:    at Adguard.Filter.Rules.InjectObject..ctor(String name, String tagName, Boolean isVoidTag, DocumentLocation runAt, String contentType, Byte[] content, IEnumerable`1 match, IEnumerable`1 include, IEnumerable`1 exclude)
   at Adguard.Filter.Rules.InjectScript..ctor(String name, String content, IEnumerable`1 match, IEnumerable`1 include, IEnumerable`1 exclude, DocumentLocation runAt)
   at Adguard.Filter.Userscripts.UserscriptManager.Register(IUserscript userscript)
   at KA9XQi7WmYo7cTPrA2.aZiR9OUm2liJTMF1YA.utrgZjO14S(IEnumerable`1 filterRules, WebFilteringModule )
   at KA9XQi7WmYo7cTPrA2.aZiR9OUm2liJTMF1YA.H4kgmkExJW()
   at Adguard.Service.ServiceLocator.DjXYPyFAAVuS0okP9GT(Object )
   at Adguard.Service.ServiceLocator.Start()
Do you see these files in Adguard's folder?
 

Dolfi

Banned
AG has several folders (as you know ;)), don't see Adguard.Html in %PROGRAMFILES%\AG
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
AG has several folders (as you know ;)), don't see it in %PROGRAMFILES%\AG
Reproduced it on Windows XP SP3 x86.

Don't know what's the problem yet but it's good that it is very easy to reproduce.
 

Dolfi

Banned
I've updated beta installer (autoupdate is disabled until tomorrow)
6137 installed and activated fine.
Many thanks, especially for not abandoning "outdated" OSes (actually updates to XP are available until 2019 - if one knows how to).
 
Top