[*] bild.de

jeriko

New Member
Hello :)

the main page bild.de shows up. But as soon as clicking on any random link adguard got detected.

enabled filters:
english filter
german filter
spyware filter
anoyances filter

google chrome, latest version

best regards
jeriko
 

jeriko

New Member
When clicking, site got detected.

I use version

Adguard AdBlocker

2.5.8

English filterVersion 1.1.2.66. Updated 8 december 2016 at 02:00.
Spyware filterVersion 1.0.9.42. Updated 7 december 2016 at 22:00.
Annoyances filterVersion 1.0.7.56. Updated 7 december 2016 at 23:02.
German filterVersion 1.0.29.10. Updated 8 december 2016 at 10:01.

Only using the chrome extension.
 

Blaz

Moderator & Translator
Staff member
Moderator
Reproduced in Extension.

When adding the rule from German filter to User filter, also doesn't work. Only if I add the older version of that rule, it works:

Old working rule:
Code:
bild.de#%#(function(){var b=function(a){a&&window.__bild!=a&&(window.__bild=a,window.__cmsKonfig=a.cmsKonfig,Object.defineProperty(a,"cmsKonfig",{get:function(){return window.__cmsKonfig},set:function(a){a&&a.system&&a.system.ad_smart_site_id&&(a.a=void 0,a.system.ad_smart_site_id=void 0);window.__cmsKonfig=a}}))},c=function(a){window.__de!=a&&(window.__de=a,b(window.__de.bild),Object.defineProperty(window.__de,"bild",{get:function(){return window.__bild},set:function(a){b(a)}}))};Object.defineProperty(window, "de",{get:function(){return window.__de},set:function(a){c(a)}})})();
New non-working rule (currently in German filter):
Code:
bild.de#%#(function(){try{var b=function(a){a&&window.__bild!=a&&(window.__bild=a,window.__cmsKonfig=a.cmsKonfig,Object.defineProperty(a,"cmsKonfig",{get:function(){return window.__cmsKonfig},set:function(a){a&&a.system&&a.system.ad_smart_site_id&&(a.a=void 0,a.system.ad_smart_site_id=void 0);window.__cmsKonfig=a}}))},c=function(a){window.__de!=a&&(window.__de=a,b(window.__de.bild),Object.defineProperty(window.__de,"bild",{get:function(){return window.__bild},set:function(a){b(a)}}))};Object.defineProperty(window, "de",{get:function(){return window.__de},set:function(a){c(a)}})}catch(a){console&&console.error&&console.error(a)}})();
 

jeriko

New Member
Okay, does not work again (clearing cache does NOT resolve issue)

Whats steps do i have to do to solve this problem?

best regards
 

Blaz

Moderator & Translator
Staff member
Moderator
It looks like some problem with Javascript on their site with Extension only.
You may try to install Adguard for Windows until the problem with Extension and bild.de is solved.

EDIT: It seems it is reproducable when visiting the link and when it works, pressing on Refresh button.
EDIT2: Try these rules meanwhile:
Code:
@@||sascdn.com$domain=bild.de
@@||smartadserver.com^$domain=bild.de
@@||visualrevenue.com/vrs.js^$domain=bild.de
@@||bild.de^$generichide
bild.de#$#.tea-skyscraper { position: absolute!important; left: -2000px!important; }
 
Last edited:

Blaz

Moderator & Translator
Staff member
Moderator
Can you please check with the mentioned rule above, thank you.
 

jeriko

New Member
Currently i am away from keyboard

I will test and answer if i am back!

Thx in advance for the fast support. Excellent!
 

Blaz

Moderator & Translator
Staff member
Moderator
They should be for Extension list only (currently in the works).
Extension is a few seconds slower in executing javascript rules than Adguard for Windows and therefore the detection sometimes happen.
 

Alex302

Filters Developer
Staff member
Administrator
@jeriko please try to disable user filter and enable Safari filter. This site works fine on iPad, which doesn't support JS rules.
 

Alex302

Filters Developer
Staff member
Administrator
Or just add these rules
Code:
@@||smartadserver.com/diff/*/partners/$domain=bild.de
@@||smartadserver.com/diff/*/smartad.js$domain=bild.de
@@||sascdn.com^$domain=bild.de,script
 

jeriko

New Member
With using Safari filter, site works.

What does affect performance more? Adding safari filter or just adding these three lines in custom rules?
 

Alex302

Filters Developer
Staff member
Administrator
In general - nothing. But in Safari filter we use more wide unblocking rules.
Did you thy that 3 rules without Safari filter?
 
Top