bing.com is not responding due to a long-running script.

Discussion in 'Technical Support (AdGuard for Windows)' started by Claus Schiroky, Oct 30, 2018.

  1. Claus Schiroky

    Claus Schiroky New Member

    Joined:
    Oct 30, 2018
    Messages:
    5
    Hi,
    I do see Edge freeze when AdGuard is loaded (regardless if browser extension is loaded on top or not): when I type any keyword into the search filed within Edge (Windows 10 Pro) on Bing.com, it freeze. Some seconds later I see the error "bing.com is not responding due to a long-running script".
    This happen only on Bing. It does not occur with other search sites, like Google.
    How to fix this? I like to use Bing instead of Google!
    Best Regards,
    Claus
     
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,948
    Does it work if you disable AdGuard?
     
  3. Claus Schiroky

    Claus Schiroky New Member

    Joined:
    Oct 30, 2018
    Messages:
    5
    Hi,
    Yes, if I fully disable AdGuard there's no problem. I can also work-around, with AdGuard started, by disabling the modules "Ad Blocker", and "AdGuard Extension".
    Best Regards,
    Claus
     
  4. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,568
    Please try the latest Nightly build (in settings you can switch the update channel to Nightly and then update via Tray icon -> About).

    I can't reproduce on latest nightly. Which Windows 10 build are you running ( 1809/1803 etc.)?
     
  5. Claus Schiroky

    Claus Schiroky New Member

    Joined:
    Oct 30, 2018
    Messages:
    5
    Hi,
    have tried, problem persist.
    I'm running on Windows 10 Enterprise here, 10.0.17763.55.
    Best Regards,
    Claus
     
  6. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,948
    What filter lists do you have enabled? Are you using AdGuard for Windows (the desktop) app or the AdGuard Adblocker browser extension for Microsoft Edge? Or are you using both? If you're using both, you don't need the AdGuard Adblocker browser extension for Edge if you're already using AdGuard for Windows and would recommend removing it (also integration mode with AG for Windows and the AG Edge browser extension doesn't work).
     
  7. Claus Schiroky

    Claus Schiroky New Member

    Joined:
    Oct 30, 2018
    Messages:
    5
    Hi,
    I do have the setup default filter lists enabled.
    I'm using the desktop app. I already have tested with dedicated AdBuard AdBlocker browser extension for Edge (with the desktop app not installed/removed). As result the problem does not occur.
    Hence, no problem when using only the browser extension.
    If I have the desktop app installed in parallel - I have the problem. If I remove the browser extension (so only the desktop app installed) - I do have the problem.
    Hence, as long as I have the desktop app installed (with or without the browser extension installed in parallel) the problem occur.
    As the desktop app is more powerful, and also I have payed for, I like to use it - without the problem.
    Best Regards,
    Claus
     
  8. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,285
    @Claus Schiroky

    Hello!

    Let's try this option:

    Right mouse button on AdGuard icon (from the tray) - Advanced - Settings - Block TCP fast open (uncheck) and restart Microsoft Edge.
     
  9. Claus Schiroky

    Claus Schiroky New Member

    Joined:
    Oct 30, 2018
    Messages:
    5
    Hi,
    did not need to run that test. I simply removed AdGuard, restart System, and resintalled the software. Now it's working without problems.
    Can't see any difference in the settings, anway, problem solved.
    Thank you,
    Claus