Bugs on the new beta 5.10.1128

fabjazz

Beta Tester
Hi !

after installing the last version of adguard beta 5.10.1228 and french easy list, after an update of the list, I don't arrive to connect to google.fr, gmail, news... All services of google are blocked, on maxthon (4.4.1.2000) and opera (22.0).
When I remove fr list, all become normal.

And another bug, the links for the connection of the forum [log in] and [reset fields] does not appear anymore, I must to disable ad blocker to connect to the forum.

edit: Finaly all the forum content is filtered, not just the links. Obliged to return to 5.9 to be protected for the moment..

edit 2: another beta test today, all is working good with fr easy list, google and forum... Don't know why, I haven't changed anything
 
Last edited by a moderator:

marke68

Beta Tester
I wasn't sure whether to start a new thread for this bug so i'll just put it in this thread.

Basically i went to do a google search for something and the search never completed in Opera so i switched to Firefox and the same thing happened,when i disabled Adguard protection the search went just as it should have with both browsers.

Here's the log.

Address: http://www.google.co.uk/search?client=opera&q=Motorola+Moto+G&sourceid=opera&ie=UTF-8&oe=UTF-8
Time: 07/12/2014 22:45:41
Status: Error
Request details:

The following rule exception was activated:
@@//www.google.*/search$urlblock

Error processing the request:
System.ArgumentOutOfRangeException: Index and length must refer to a location within the string.
Parameter name: length
Source: mscorlib
Stack trace: at System.String.Substring(Int32 startIndex, Int32 length)
at Adguard.Filter.Rules.ShortcutsLookupTable.LookupRules(String url)
at Adguard.Filter.Rules.UrlFilter.IsFiltered(String url, String referrer, Boolean isAjaRequest, Boolean isSubdocument, Boolean isObjectSubrequest)
at Adguard.Filter.RequestFilter.InnerFilterHttpRequest(String requestUrl, String referrer, FilteringContext filteringContext, Boolean isAjaRequest, Boolean isSubdocument, Boolean isObjectSubrequest)
at Adguard.Filter.RequestFilter.CheckCollapseRules(HtmlElement element, FilteringContext context)
at Adguard.Filter.RequestFilter.FilterElement(HtmlElement element, FilteringContext context)
at Adguard.Filter.Parser.ContentEditor.CheckRemovedRange(HtmlElement element)
at Adguard.Html.ContentEditingHtmlParser.OnEndElement(HtmlElement element, ParsingContext context)
at Adguard.Html.HtmlParser.OnStartTagFound(HtmlElement element, Tag endTag, ParsingContext context)
at Adguard.Html.HtmlParser.ProcessEndTag(Tag tag, ParsingContext context)
at Adguard.Html.HtmlParser.ParseTags(ParsingContext context)
at Adguard.Html.HtmlParser.Parse(ParsingContext context)
at Adguard.Filter.Http.HttpResponseFilter.FilterPage(FilteringContext filteringContext, HttpRequest request, Encoding pageEncoding, PeekingStream inputStream, Stream responseStream)
at Adguard.Filter.Http.HttpResponseFilter.FilterFixedLengthResponse(FilteringContext filteringContext, HttpRequest request, HttpResponse response, Encoding pageEncoding, PeekingStream inputStream, Stream responseStream)
at Adguard.Filter.Http.HttpResponseFilter.FilterHtmlResponse(HttpRequest request, HttpResponse response, Stream responseStream, FilteringContext filteringContext)
at Adguard.Filter.Http.HttpResponseFilter.FilterResponse(HttpRequest request, HttpResponse response, Stream responseStream, FilteringContext filteringContext)
at Adguard.Network.Filter.HttpFilter.ProcessRequest(HttpRequest request, FilteringContext filteringContext, RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.ProcessConnection(RecordingStream localRecordingStream, RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.Filter()



New element hiding rules have been added to the page
Popup blocking code has been added to the page

Bytes received: 444154
Bytes sent: 1126

Hope this is of some help to you.
 

avatar

Administrator
Staff member
Administrator
Hi !

after installing the last version of adguard beta 5.10.1228 and french easy list, after an update of the list, I don't arrive to connect to google.fr, gmail, news... All services of google are blocked, on maxthon (4.4.1.2000) and opera (22.0).
When I remove fr list, all become normal.

And another bug, the links for the connection of the forum [log in] and [reset fields] does not appear anymore, I must to disable ad blocker to connect to the forum.

edit: Finaly all the forum content is filtered, not just the links. Obliged to return to 5.9 to be protected for the moment..

edit 2: another beta test today, all is working good with fr easy list, google and forum... Don't know why, I haven't changed anything
Thank you fabjazz! We'll check what could be wrong with Liste FR. There could be some compatibility issues with ABP rules I hope we'll fix it soon.

---------- Post added at 11:25 AM ---------- Previous post was at 11:25 AM ----------

I wasn't sure whether to start a new thread for this bug so i'll just put it in this thread.
Thank you! This bug will be fixed in today's beta release.
 

Ghost5525

Beta Tester
I've noticed that when I go to some sites with embedded flash videos the videos will play but soon after it says the plug in has stopped responding (I've seen this on Firefox 31 and the latest Stable of Chrome). Am I missing something in my filter or have others had this happen to - didn't want to submit a bug if it was known.
 

avatar

Administrator
Staff member
Administrator
I've noticed that when I go to some sites with embedded flash videos the videos will play but soon after it says the plug in has stopped responding (I've seen this on Firefox 31 and the latest Stable of Chrome). Am I missing something in my filter or have others had this happen to - didn't want to submit a bug if it was known.
I am not sure this has something to do with Adguard. Could be flash player bug.
 

Ghost5525

Beta Tester
I am not sure this has something to do with Adguard. Could be flash player bug.
I'll try to see if my flash player is updated (should be 14.x.x.x) so if i experience it again i'll try to let you guys know more i just didn't want to report a bug and it be unrelated to the app
 
Top