Can’t stop AdGuard from filtering Safari

benbenb

New Member
Hi there,

as for browser usage I have several browsers installed. All of them should be filtered by AdGuard, except Safari. Unfortunately that doesn’t work: I unticked Safari within the preferences pane from the filtered applications. I have even kicked out Safari completely. Nevertheless, as long AdGuard is running, it continues filtering Safari. For all other browsers it works as it should once the browser is unticked within the filtered applications.

Am I too stupid or is it bug? Hope someone can help me out on this.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
Hello there!
That's really weird.

If you open the filtering log before surfing your Safari browser. Will the log display any requests?
And maybe you use a separate AdGuard for Safari browser extension?

1573221360588.png
 

benbenb

New Member
Thanks for your fast response!
I don’t use the separate browser plugin. As to the filtering log: yes, though Safari is unticked within the filtered applications, there are are lot of requests. Once I start Safari, it starts filling up with requests...
 

benbenb

New Member
Hey, anyways, your tip to check out the log helped. I guess I found the bug!

Within the log Safari entries shows up as Maxthon browser. Once I also uncheck Maxthon browser, AdGuard stops filtering Safari. It seems that in the background of the app there is simply a small “wrong wiring” and Safari and Maxthon are switched up.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
I've just tried to figure this out. And here's what I managed to find out.
Several programs use one system process to get web content. Therefore, there is such a situation.
 

benbenb

New Member
I believe I am getting what you say. In this case I am afraid the section for choosing which apps/browser should be filtered or not needs some re-work. If you are right, AdGuard can’t handle the users "choice" it in a reliable way.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
I reported this situation to the developers. I think they will fix this issue.
 
Top