Cannot Log into Modem as login page broken by adguard

Discussion in 'False Positives' started by AnthonyG, Aug 15, 2014.

  1. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    This is going to be a tough one to explain.

    I have a HG612 FTTC modem. There is a custom firmware you can get for it that brings up a menu that you can see your line stats.

    The problem is Adguard is breaking the login page for it.

    The way you log into it is by putting in the LAN IP address you have assigned, so for me its 192.168.1.253.

    With Adguard running all I see is a load of javascript code.

    I have added both a snapshot of the working page, and the one not working due to Adguard.

    How do I fix this as I don't want to keep disabling Adguard to log into my modem

    Thanks
     

    Attached Files:

  2. jeffhere

    jeffhere New Member

    Joined:
    Aug 14, 2014
    Messages:
    15
    can't you whitelist the url (in your case ip address) to get to that screen? Disable adguard and capture the url's and add them to the white list function...no?
     
  3. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,300
    You're the second person whom has mentioned this today. Must be a bad rule in the latest filter updates.
     
  4. vvgNovanet

    vvgNovanet Moderator Moderator

    Joined:
    Nov 9, 2010
    Messages:
    4,569
    Add a custom filter rule
    Code:
    @@||192.168.1.253$document
     
  5. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,300
    I wonder if this would work;

    Code:
    @@||192.168.*.*$document
     
  6. vvgNovanet

    vvgNovanet Moderator Moderator

    Joined:
    Nov 9, 2010
    Messages:
    4,569
    Works for me. :)
     
  7. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    Thanks for the help but I tried both

    @@||192.168.*.*$document

    @@||192.168.1.253$document

    And neither worked.

    To confirm I am doing it right, I went to Settings, Adblocker, use filter list, clicked on an empty box that has my custom filters listed from using the page section blocker addon, and pasted those in and then made sure there was a tick at the end on enabled. Neither works.

    Is there a different way to add an exception?
     
  8. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,300
    Okay, try this variant...

    Code:
    @@||192.168.*.*$elemhide,content,urlblock,jsinject
     
  9. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    I think I had this problem in the not so distant past. What filter lists are you using?

    **** Also try unplugging the modem, wait about 30 seconds, then plug in the modem.
     
    Last edited by a moderator: Aug 15, 2014
  10. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    Still not working with

    @@||192.168.*.*$elemhide,content,urlblock,jsinject

    I really am thinking I am doing something wrong here.

    User filter (and this is the one I am adding the above to)
    English
    Spyware
    Filter for useful ads

    Tried turning off for 5 mins but on turning back on no joy.

    The other thing to mention if I disabled Adguard. And then log in and then turn back on Adguard. What happens is every link inside my modem settings page it starts to want to download files (html files) that are called that link.

    And clicking on stats lists the boxes are totally empty.

    Turning off Adguard fixes all the above instantly.
     
    Last edited by a moderator: Aug 15, 2014
  11. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Last edited by a moderator: Aug 15, 2014
  12. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    Disabled everyone of them one after the other until every filter was off (then got a popup saying the English fiter should be on so it was automatically re-enabling that one, so then disabled that feature and turned it back off).

    But with every filter disabled it did not fix it.

    So this suggests its something else inside adguard causing this than a filter. Could it be parental blockers perhaps? Or something else that Adguard does outside of the filters?

    *Edit* Just looked I have Parental controls turned off. The only other thing I can see outside of the filters section is the browser security tab?

    Not for this specific problem as the issue I am having is the router login page will not come up.

    Its literally the same if you went to 192.168.1.1 and tried to log into your router on that page (which is the default for the HG612). I just changed it to 253 to not clash with my asus router which was already using that IP. But its just not coming up. The asus router comes up. But the HG612 is affected by something in Adguard.

    Thanks for everyones help on fixing this by the way.
     
  13. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Did you check the Network tab for any options that might be the culprit?
     
  14. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    This probably wont be of any help to this but I have went through everything disabling everything I can find and nothing fixed it until I went to

    network > Traffic filtering and changed from Automatically filter browser traffic to use Adguard as a HTTP proxy and I chucked in port 81 (or port 80 for that matter). Worked straight away after that. But unless I misunderstand the above. I don't think that is a fix as it will break Adguard doing this.

    But to mention on the main protection page disabling Adblocker tab section as a whole - didn't fix it, neither did disabling broswer security and parental controls as a whole neither.
     
    Last edited by a moderator: Aug 15, 2014
  15. Accel

    Accel Beta Tester

    Joined:
    Oct 8, 2012
    Messages:
    238
    it is english filter, I'm experiencing it as well.
     
  16. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    Is there anyway I can ask for this to be fixed. As this really is starting to become a deal breaker as I am spending most times with Adguard turned off to allow me to run my modem line stats.

    This for me is as bad as Admunchers non SSL protection.
     
  17. AnthonyG

    AnthonyG Member

    Joined:
    Jul 18, 2014
    Messages:
    44
    I guess a workaround for this is I have disabled all protection for Internet Explorer in Adguard and have this for the modem. And am using my normal browsers for adblocking and browsing the net.

    So it seems the issue is sort of resolved. But it would be nice to have Adblocker fix this.
     
  18. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,300
    Do you have any sort of anti-virus, proxy/VPN, sandbox or any other kinds of software like that running? Posting some specs may help with trying to reproduce this issue.
     
  19. Accel

    Accel Beta Tester

    Joined:
    Oct 8, 2012
    Messages:
    238
    it is happening with TP Link modem page

    i use below rule to whitelist it

    @@||192.168.*.*$document