Can't AirDrop and no images load in email — Monterey M1

Uranium235

New Member
I have the latest version of AdGuard Pro (2.6.1.1051 release (CL-1.8.221, DNS-1.6.58)) running on a 16" M1 Max MacBook Pro with Monterey 12.0.1.

  1. My first issue is that I can't AirDrop to my iPhone or iPad when AdGuard is running. If I quit AdGuard completely, AirDrop works fine. How can I enabled AirDrop without having to quit AdGuard every time I need to?
  2. My second issue is probably something to do with Monterey. No images load in any emails I receive (Mail app for Mac). Each email with imagery instead shows an error message: "Your network preferences prevent content from loading privately." Does this has something to do with the AdGuard VPN profile and is there a way to allow images to load?
Thank you.
 

oldsarge

Member
I am having a similar issue but only with Mail (I don't use air drop). I just upgraded to Monterey this evening. I noticed that the Mail application now has protection and images/content is blocked. I too have the same message upper left "Your network preferences....." In the upper right I can select "load content directly" which when selected loads all images/content. Sort of a nuisance. In AG, under network, Automatically filter applications, Mail is checked.

As far as I know since I rarely ever dig into my system, it has always been checked along with all other listed applications. I am guessing this is a Monterey issue beefing up mail security. My question is whether 'unchecking' mail in the AG Network settings. is a wise move or am I better off and more secure or equally secure in unchecking "Protect Mail Activity". Also, "Hide IP address" is also checked. Should this also be checked or unchecked?

Tonight is the first time I have dug into my system to this depth and I have no idea what setting were in place before the upgrade. I sure could use some advice. As I said, loading the info is a nuisance but 'livable' if necessary. Thanks in advance
Screen Shot 2021-11-01 at 7.58.58 PM.pngScreen Shot 2021-11-01 at 8.07.11 PM.png
 
Last edited:

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Hello there!

These are known issues and we are working on a solution.

1. Airdrop
2. Mail.app and Protect mail activity

As a workaround, you can open AdGuard settings -> Gear -> Advanced -> Advanced settings -> Change network.extension.monterey.force.split.tunnel to true value
 

oldsarge

Member
Chinaski - Thanks. That is just a bit too technical for me. I will put up with the nuisance of "loading content directly". A small price to pay and again my thanks.
Screen Shot 2021-11-02 at 4.46.59 PM.png
 

EJohnson

New Member
Hello there!

These are known issues and we are working on a solution.

1. Airdrop
2. Mail.app and Protect mail activity

As a workaround, you can open AdGuard settings -> Gear -> Advanced -> Advanced settings -> Change network.extension.monterey.force.split.tunnel to true value
Thanks for the workaround, totally easy to implement and it works. :)
 

oldsarge

Member
Hello there!

These are known issues and we are working on a solution.

1. Airdrop
2. Mail.app and Protect mail activity

As a workaround, you can open AdGuard settings -> Gear -> Advanced -> Advanced settings -> Change network.extension.monterey.force.split.tunnel to true value
It took me 7 days but I changed the false to true. All is well! Thanks Chinaski!
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Glad to inform you that this issue is fixed in the latest Nightly version of AdGuard for macOS.
 

oldsarge

Member
Chinaski - IF I download the nightly version, do I need to reset from true to false ? Will installing the nightly version automatically reset the the true to false as an automatic return to default settings? Also, since I am not familiar with the nightly version, is it sort of a temporary fix until the next regular update takes effect? Thanks in advance. No need to hurry.
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Chinaski - IF I download the nightly version, do I need to reset from true to false ? Will installing the nightly version automatically reset the the true to false as an automatic return to default settings? Also, since I am not familiar with the nightly version, is it sort of a temporary fix until the next regular update takes effect? Thanks in advance. No need to hurry.
1. You need to reset net.ext.mntr.force.split.tunnel manually
2. Yes, the Nithgly version is designed to fix issues missed in the release. Also, this update channel is the first to get new features.
Eventually, all of these changes go into beta first and then become a release.
 

creid

New Member
I installed nightly build 2.6.2.1066, and the issue was not fixed with respect to images in Mail. The only solution that has worked for me is changing net.ext.mntr.force.split.tunnel to true.
 

creid

New Member
Just installed nightly 2.7.0.1073, and issue still not fixed. Reset net.ext.mntr.force.split.tunnel to false and restarted Mail and AdGuard. New messages came in unable to load images. Setting net.ext.mntr.force.split.tunnel back to true resolved it.
 

creid

New Member
Still wondering when this will be fixed. Updated to 2.7.0.1089 nightly, reset net.ext.mntr.force.split.tunnel to false, restarted Mail and AdGuard. New messages came in unable to load images. Setting net.ext.mntr.force.split.tunnel back to true resolved it.
 
Top