Cant get nightly to work anymore.


Beta Tester
A while back (it wasn't that long ago, but I can't remember when now) while I was using nightly I got an update, and nightly stopped working. I decided to uninstall and go to stable for a while, assuming it was a bug.

Since then I have tried Nightly a couple of times and each time as soon as I upgrade to nightly it stops working completely. It works as normal in stable (beta is currently the same version), but will not do anything in any browser I use in nightly. If it was just not working in a single browser I might be able to figure it out, but as it seems to be doing nothing at all on my laptop I don't know where to look.

I have tried with all the extensions and filters I use loaded, and also with just the base filter and nothing else.

Does anyone have any idea what to look for or what could be the issue?

Windows 7 Pro
Adguard 6.4.1528.4331
Firefox 61.0.2 (with fresh profile and no addons no change)
Opera 55.0.2994.37
Kaspersky Free AV (Closing Kaspersky has no effect)




First of all, we need to figure out what exactly happens when you use a Nightly version. (Please provide screenshots or more detailed information about the issue you facing at)

To solve this problem send the log files to with a described situation.


Beta Tester
I was using the extension briefly while I was busy.

I am not sure what screenshots to give, there are no errors or anything to show. It just doesn't do anything one it is nightly.

I just reinstalled and the release worked as normal blocking ads, and assistant working. I changed to nightly in settings, and updated. It instantly stopped doing anything. No ads blocked, no assistant. Adguard gives no error and the service is running etc.

I am just about to send the logs.


Beta Tester
I noticed your reply, thought I would let you know it is back working.

The initial advice from support did not help, to reinstall directly from the nightly installer download if restarting doesn't work. But later that same day a new update to nightly came through (6.4.1543.4361), and after the update Adguard was working again.

Boo Berry

Moderator + Beta Tester
Looks like the TDI driver was broken in the last nightly build, but it's fixed now in the newest nightly build.


Beta Tester
Stopped working after an update to 6.4.1601.4477 today. Restarted browser and adguard. Reinstalled certificate. I don't want to have to reinstall adguard if possible, and set it up again, but I can if needed.


Moderator & Translator
Staff member
Is the filtering log showing any requests in nightly?
Is your browser activated in "Filtered apps"? Did you try changing to WFP/TDI driver (uncheck WFP for TDI and reboot)?
Last edited:


Beta Tester
Filtering log was empty, all browsers were in the list.

I had already restarted the computer generally, but ticked WFP and restarted to try. It didn't do anything. So I unticked it again and restarted, now Adguard is working again . . . . .

Seems a little convoluted, but if it stops working again in the future I will try restarting with both drivers before posting.