Can't install the licensed version on my tablet--no where to enter activation code


New Member
I have AdGuard installed on my Windows laptop and one phone so far. I tried
adding it to my tablet. It is letting ads into the Samsung browser on

I noticed on my phone, AdGuard has two app icons. One is just AdGuard, the other
AdGuard Content Blocker. I do not have both of these icons on my tablet's list
of programs. There seems to be no place to add the activation code, either, on
the AdGuard that's on my tablet. I suspect I need the other part of AdGuard that
my phone has.

My tablet is also not listed in my list of devices under my account, so I believe I
don't have the paid version on the tablet (I have a 9-device lifetime license). So do I
have a trial version installed on my tablet? I see you have a trial version but
the Play Store didn't say it was a trial. When I installed it on my phone
successfully, there were two app icons, and I only see one on my tablet. I'm
overlooking something here. I don't see any other AdGuard apps to download in
the play store.

I'd also like to understand why my phone has two app icons and my tablet only one for it?


New Member
Thanks. That worked. Why did it install itself on the phone version and not the tablet? On the phone, I did not have to install an APK. Neither device is rooted.