Can't use app with cell data connection

Discussion in 'Technical Support (AdGuard for Android)' started by EliezerB, Jan 27, 2015.

  1. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    Currently the app works well when on WiFi but not at all via my cell data connection. I have a non-rooted Samsung Galaxy S4.
    Please see the attached three screenshots. These are the settings on my phone that I must use for my cell provider. Does the app have settings that would accommodate my phone's settings?

    Thanks,
    Eliezer
     

    Attached Files:

  2. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,902
    Hi! Could you please describe in more details what exactly doesn't work with cell data connection?
     
  3. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Hi @EliezerB!

    I've just answered your ticket.

    The problem is that you use proxy mode with manual setup.
    In this case filtering is possible for Wi-Fi only.

    Why don't you use VPN mode?
     
  4. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    When I am on my mobile data connection I get this when trying to access an HTTP webpage:
    The request is not understood.
    Technical description:
    400 Bad Request - Check your spelling for the requested URL.​

    And this for an HTTPS page:
    SSL connection error
    Hide details
    Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
    Error code: ERR_SSL_PROTOCOL_ERROR​

    As far as your question about using VPN mode - it is in VPN mode, isn't it? Please see screenshot:
    Screenshot_2015-01-28-09-00-53.png
     
    Last edited by a moderator: Jan 28, 2015
  5. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Wow, do you get it in VPN mode?
     
  6. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    Yes. What I just said above (posted about 5 minutes ago) is in VPN mode.
     
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Oh, finally I've found the log and I see these 400 bad request errors.

    Now I understand why you have this issue.
    The problem is that Adguard doesn't know about an upstream proxy set in your APN settings.
    So it changes request and the upstream proxy cannot parse it.

    I've created an issue in our bug tracker, we'll fix it in one of the future versions.

    Thank you!
     
  8. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    I really would like to use the app!... Any idea when that fix might get released?
     
  9. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Bug has high priority, I hope we'll fix this in the closest major release (a month or two from now).

    ---------- Post added at 06:37 PM ---------- Previous post was at 06:35 PM ----------

    First it will be fixed in beta. If you want - I can send you a message when it's ready.
     
  10. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    Yes, please do!
     
  11. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    Is it possible for me to create a new set of APN settings that would satisfy the requirements needed to connect to my cellular data while simultaneously allowing me to use (the current release of) Ad-Guard?
     
    Last edited by a moderator: Feb 3, 2015
  12. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    The only way to fix it is to use APN without proxy. Is it possible?
     
  13. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    This is from my provider:

    So to answer your question in your last post, I guess that's a "no"...

    Also, I noticed something different this morning - and I haven't made any changes at all on my side. I was able to open webpages (both HTTP and HTTPS) while on my cellular data connection. The ad blocking didn't work at all, but the pages loaded successfully - all while showing the "key" VPN icon and AdGuard was enabled. What changed?

    Update
    I just tried this:
    - I blanked out the Proxy. It now says "Not set".
    - I left the Port at "80".

    It seems to be working now: the app seems to be filtering ads while I'm on my cellular data connection!
     
    Last edited by a moderator: Feb 3, 2015
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Guess this proxy is not mandatory.

    Anyway new beta version will be ready this week.
    I'll be thankful if you'll be able to test it with that proxy.
     
  15. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Hi @EliezerB!

    We've just released new beta version that should fix this Adguard-Proxy incompatibity in VPN mode.

    Link to installer: https://adguard.com/apkb
     
  16. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    Do I need to uninstall the regular app before installing the beta version?
     
  17. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    No, just download and run the installer
     
  18. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    When I set the proxy back to:proxy.mvno.telrite.com
    The beta version didn't work. I got "Access forbidden"
    The good news is that if I blank out the proxy, even the regular release of the app works...
     
  19. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Access forbidden is something new, it was some SSL error before.

    Could you please collect full log for us again?
     
  20. EliezerB

    EliezerB New Member

    Joined:
    Jan 27, 2015
    Messages:
    11
    It's really weird because this time it did work. I captured the logs and submitted it in
    Ticket ID: BPZ-440-84079

    Update: I tried again and although web pages loaded successfully, ads were not blocked. This is when I had the proxy set with the value that my cellular provider claims is required. I sent logs again:
    Ticket ID: PQS-309-65984

    Like I said before, though, the app is now working for me when the proxy is blank.

    Please consider linking this entire issue to other feedback I've submitted in
    Ticket ID: SJI-700-77904
    :)
     
    Last edited by a moderator: Feb 5, 2015