Captchas do not display!

jaxdrek

New Member
When I disable adguard in firefox the captchas appear well. But when I activate adguard, they do not show up at all! And I can not validate them! I specify what i use the latest version of firefox and adguard extension.

Can you make an adguard update to fix this big problem please???thank you in advance!
 

jaxdrek

New Member
Hello,
This happens on all sites using the captcha.I have left the filters original.I have not touched to filters I just installed the extension and that's all
 

Boo Berry

Moderator + Beta Tester
Moderator
Can you list some sites where this happens? Also, can you list the list of enabled filters? Thanks! :)
 

jaxdrek

New Member
I think you will not be able to access these sites because they are French. Because I live in France.here they are :

https://social-sb.com/z/anniversaire-50-ans?

https://ubishaker.com/fr/31/1495633754986884/register

http://social-sb.com/z/concourspassfestoff?

- I specify that the captchas on these links are all displayed under google chrome or microsoft edge and also have the extension adguard.Mais I just realized one thing !!!! This:
-sous firefox my extension adguard version 2.5.11 is developed by: andrey meshkov.
- But my extension adguard under google chrome is the latest version 2.6.5 but it is written: proposed by adguard.com and not andrey meshkov!
-And my extention adguard under microsoft edge is the latest version 2.5.18 also developed by adguard.com.And captchas works very well.

Maybe the adguard extension of andrey meshkov is not as well developed and bug compared to adguard of adguard.com ?

- Here as you ask me, the screenshot of my list enabled filters of adguard under firefox:





 

Boo Berry

Moderator + Beta Tester
Moderator
Andrey Meshkov aka @avatar is one the founders and the team leader of Adguard. Not sure if they could change the AMO name for the Firefox extension or not, but I don't think it matters that much.

Anyways, in my opinion, that's WAY too many filters to have enabled. I'd stick to only enabling 5 filters maximum, but that's me. In this case I'd disable the "Activate the most appropriate filters automatically" option (the third switch of the three found at the top in the first screenshot - I'd also disable the first switch too (the "Allow search ads and websites' self-promotion" option), but leave the middle switch (the "Indicate the number of blocked ads on the Adguard extension icon" option) checked). Very, VERY likely is one of those enabled filters is breaking the captchas.

Actually, looks like the Adguard team provides a French filter (which is based on Liste FR + Adguard's own additional filter rules). Not sure if it's in the 2.5 browser extensions though, but I do know it's in the 2.6 betas. If that filter is available, I'd start by enabling that one and going from there with a few more filters (not Liste FR, since the French filter already contains it).
 

jaxdrek

New Member
Hello,thank you boo berry and vasily_bagirov for your answers and for your help! I noticed your methods.But i excuse me.Because i'm not sure that adguard finally be the fault. Because I use a firefox extension named: "Zoom page WE" of the developer: dw-dev , and this extension can zoom the text of the web pages. And when you zoome a little too much, i realized that the captchas disappear! But a few days ago, when i desactivated adguard, the captcha had reappeared on a website and of the blow i was convinced that he alone was the culpable...i will be carefull to the future,thank you for your help :)
 

vasily_bagirov

Administrator
Staff member
Administrator
@jaxdrek so the problem only present if both Adguard and this extension are enabled? In this case, maybe we can look into it. Please let us know all the necessary details (browser version, Adguard version, Zoom page WE version and any settings inside this extension if they are relevant).
 

jaxdrek

New Member
Hello :), yes my version of firefox is 54.0.1.My extension adguard adblocker is 2.5.11 and my extension zoom page WE is version 5.1. But at the moment I disabled the latter. Because on some sites, for example msn, it zooms the text, yes, but the news in pictures are cut, come out of the screen because too zoomed, so I disabled it, and then at least the captchas do not disappear more. I think you can put my subject in solved :) thank you very much for your help
 

Seph

New Member
I want to confirm that this is happening independent of the version of Firefox installed and it is not due to any installed filters. It is a problem with one of the recent updates to the addon itself.

I tested several versions of Firefox (i.e., 54, 55, and 56) with all other addons disabled and found that the bug occurred in all of these versions. Specifically Google reCAPTCHAs would appear and then instantly disappear. I also noticed that the dropdown menu from clicking the Adguard button was missing and when manually going to the moz-extension:// page for the addon all of the settings were missing.

When installing a different version of the addon (viz., adblocker-2.5.19-beta) the functionality of the reCAPTCHA and dropdown menu were restored in all versions of Firefox tested.

I somehow forgot to take a screenshot of the visual bug, but the dropdown menu would sort of appear and get cut off at the bottom of the Firefox top panel chrome. It almost seems like somehow the CAPTCHAs and menu are glitching behind the top layer of the browser somehow. It is as if the menu and reCAPTCHA are being rendered, but hidden behind something somehow.

I'm sorry I'm having difficulty explaining what I think the problem is, but I think these details should help isolate the cause.

Thank you for making an amazing addon!
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
My bet is one of the filter lists is causing this. What filter list(s) do you have enabled? Does disabling all of them make the issue go away? Isolating the issue to a specific filter list would be a great help indeed. :)
 

Seph

New Member
My bet is one of the filter lists is causing this. What filter list(s) do you have enabled? Does disabling all of them make the issue go away? Isolating the issue to a specific filter list would be a great help indeed. :)
If it were one of the filters, then why would identical filters used with 2.5.19-beta not reproduce the problem?
 

Boo Berry

Moderator + Beta Tester
Moderator
There's support for new type(s) of filter rules in the newer extension builds, so that could be why.
 

Seph

New Member
This is really odd. It seems I was wrong with what reproduces the problem. Perhaps it isn't dependent on the version of the browser or version of the addon, but rather some other event that at least appears random. I've been using Firefox v56 (x64) on Windows 10 with the Adguard 2.5.19-beta extension and it was working fine for a while, but the problem reoccurred. I don't know what is causing it, but I know what some of the effects are:

a) extension settings seem to be reverted (I had disabled the display of the no. of filtered ads on the extension button, but after the glitch occurs, it displays the no. again)
b) the dropdown menu becomes cut off at the edge of the top Firefox chrome (see the attached screenshot)
c) Google reCAPTCHAs immediately disappear upon loading
d) all settings and options disappear from the moz-extension:// page
 

Attachments

Top