CarPlay

Discussion in 'Technical Support (AdGuard for iOS)' started by Maxime, Jul 11, 2018.

  1. Maxime

    Maxime New Member

    Joined:
    Jul 11, 2018
    Messages:
    3
    Hi, it seems there is an issue related to Apple CarPlay.

    Let me explain this, when AdGuard is enabled and I’m in my driveway, my phone(iPhone 7 Plus) is connected to my home network wifi. I plug my phone into my car (2016 Ford Edge) headunit, CarPlay starts I put a song and select my destination in the maps app and I drive off.

    The problem is the phone doesn’t switch to cellular network, it stays stuck on the wifi network then it freezes and CarPlay is not responsive and it shuts off. I have to unplug and plug back in the phone then it’s all good.

    This does not happen when AdGuard is disabled, the phone automatically switch to cellular network as I drive away from my house like it normally would. My 2 options are to either disable AdGuard or wifi before getting into my car every time but it sucks as I sometimes forget to enable it afterwards.

    I hope there is something that can be done to fix this.

    Thank you

    Edit: I forgot to mention I’m on the latest version of iOS and AdGuard, if that’s relevant. It was also happening on prior versions.
     
  2. zebrum

    zebrum Administrator Staff Member Administrator

    Joined:
    Nov 21, 2016
    Messages:
    512
  3. Maxime

    Maxime New Member

    Joined:
    Jul 11, 2018
    Messages:
    3
    Both, and also it's the same for split or full tunnel.
     
  4. Maxime

    Maxime New Member

    Joined:
    Jul 11, 2018
    Messages:
    3
    Should I reproduce the issue and send logs right away?
     
  5. zebrum

    zebrum Administrator Staff Member Administrator

    Joined:
    Nov 21, 2016
    Messages:
    512
    @Maxime so far no need in logs, we already have it.

    1. is wi-fi assist enabled in settings on your device? If so can you try to disable it?
    2. do you have any other VPN app to check the problem with it? TunnelBear for example, it has some free traffic.
    3. there is a possibility the problem is not on our side and you need to report it to CarPlay. Can you do that too?