Chrome + AdGuard Google Images issues

cadenwubert

New Member
I am using Chrome Version 105.0.5195.127 (Official Build) (64-bit) on a Windows 10 laptop.

I recently noticed that I cannot search for images via Google while AdGuard is on.

Steps to recreate:
Enter a search word; I used "horse"
Click on Images
Sit there while nothing happens

When I deactivate AdGuard and try it again, images of horses appear as expected. Note: Each time, I am closing Chrome and re-opening it.

When I activate AdGuard but check off every filter (Settings > Ad Blocker > Installed filters) and also turn off the setting for Ad Blocker while I'm at it, images of horses do NOT appear. I was hoping to go through each filter to figure out which one was the culprit but even with every list turned off, I still have this problem.

Meanwhile, when I switch to MS Internet Explorer Version 21H2 (OS Build 19044.2006), I have no problems with Bing search and then Images.

I'm looking for suggestions! What is it about Chrome and AdGuard that is preventting

Thank you very much,
Rob
 

cadenwubert

New Member
Hello!

I uninstalled and reinstalled AdGuard to see whether that would resolve it but no luck. As soon as I installed it, Google Images stopped working for me again. I currently have the below filters active, which would be the default from standard installation of the software.

I'm still digging around. This is a pretty interesting problem! Annoying, but interesting. I don't want to uninstall AdGuard (yet). :)

1664292502907.png
 

Boo Berry

Moderator + Beta Tester
Moderator
I can't reproduce this, and I use the same filters. I don't think it's filters, likely something else.

Do you have any stealth mode settings enabled? If so, what? DNS filtering?
 

cadenwubert

New Member
Hello!

I got to the point where I'd had everything off other than Network Settings.

1664301834247.png

My test continued to fail, which would be entering something in Chrome | Google and then clicking Images. My browser would clock and eventually give me an error.

1664301927103.png

BUT, I've found that when I turn off the checkbox for Enable Traffic Filtering, it worked. I confirmed by toggling it on and off to make sure that was it and at the moment I'm feeling confident.

1664302315277.png

The thing is, I did not have this problem before. I wonder whether you or anyone would be able to recreate my problem.

This type of stuff is beyond my technical knowledge. I've read the link below a couple of times but I'm still a little lost as to what I "should" do.


What could have updated that would result in my problem?

Alternatively, since AdGuard is just an add on product for me, any harm in leaving it off?

Thank you for all feedback! I sincerely appreciate anyone who has taken the time to read this.

Rob
 

cadenwubert

New Member
Interesting results!

In Edge, I had trouble using Google for anything. But no issues with Bing or DuckDuckGo.

Back in Chrome, with everything turned on in AdGuard, I had no trouble with Google *except* when I clicked Images. HOWEVER, I had no issues at all with Bing and DuckDuckGo, including pulling up Images.

Hmmm!

Since I have a workaround for image search using Bing or DuckDuckGo, I am fine and will deprioritize this. Obviously there is some technical interaction somewhere on my laptop causing this, since you guys do not encounter the same and it seems to be only me, and I am definitely curious, but it is deprioritized.

Thank you again to everyone that gave me testing ideas. I sincerely appreciate it! Thank you @VasqueZ and @Boo Berry.

Rob

p.s. @Boo Berry, I am using MalwareBytes and also BitDefender.
 

H3lper

Member
Staff member
Interesting results!

In Edge, I had trouble using Google for anything. But no issues with Bing or DuckDuckGo.

Back in Chrome, with everything turned on in AdGuard, I had no trouble with Google *except* when I clicked Images. HOWEVER, I had no issues at all with Bing and DuckDuckGo, including pulling up Images.

Hmmm!

Since I have a workaround for image search using Bing or DuckDuckGo, I am fine and will deprioritize this. Obviously there is some technical interaction somewhere on my laptop causing this, since you guys do not encounter the same and it seems to be only me, and I am definitely curious, but it is deprioritized.

Thank you again to everyone that gave me testing ideas. I sincerely appreciate it! Thank you @VasqueZ and @Boo Berry.

Rob

p.s. @Boo Berry, I am using MalwareBytes and also BitDefender.
What if you disable Web Protection in MalwareBytes? I've seen a few users with the same issue, one of them had to disable AV\Firewall software to get it working.
What's your results?

By the way, thank you for the detailed description of the problem.
 

Boo Berry

Moderator + Beta Tester
Moderator
Maybe it's an antivirus incompatibility with AG for Windows? Because it sure sounds like one as you're technically running two antivirus/antimalware apps at the same time along with AG for Windows, so there's bound to be weird issues like this.

@H3lper has a good idea, disabling the web filtering, HTTPS/SSL scanning feature(s) could help. There's also one other thing you could try, go into AG for Windows' Settings and in the General section scroll down and click on Advanced Settings. In Advanced Settings scroll down to the Use redirect driver mode option which by default it should be unchecked. Try checking this box and press the green Save button and reboot your PC and see if that makes any difference. If that doesn't try going back into the Advanced Settings and scroll down to the Filter localhost option which should be checked by default. Try unchecking this option and again press the green Save button and reboot your PC to see if there's any change. If not, if it's caused by an antivirus incompatibility then there's not much else that can be done about it other than removing one or both of the antivirus/antimalware apps to test and see which one (or if it's both) causing the issue.
 

CeeTee

New Member
I'm having the same issues, both with Chrome and Edge. It was fine, and now not.
Similarly, I can no longer upload images to my client's website legacy CMS, and in this case I can see what's happening - it's enforcing the use of HTTP2 for some reason, and that protocol is not supported by the CMS.
Disabling Adguard solves the issue for both cases.
 

CeeTee

New Member
Example error for a Google Images search - I've added the red for clarity
I would have thought Google is supporting HTTP2 so it would appear that HTTP2 image requests are being mangled for some reason.
I've tested on a couple of systems, one of which only has the default Windows Defender installed, and both have issues when Adguard is enabled.

This site can’t be reached
The webpage at URL-xxxx might be temporarily down or it may have moved permanently to a new web address.

ERR_HTTP2_PROTOCOL_ERROR
 

cadenwubert

New Member
Hello @CeeTee!

Here is some more testing.

My setup:

Windows 10 Home
Malwarebytes Premium 4.5.14.210; update package version 1.0.60582; component package version 1.0.1767
Bitdefender Total Security build 26.0.27.90
AdGuard 7.10.2

Ok here goes:

Rebooted the laptop
In Chrome hit <Ctrl-E> and entered a random noun into the search area
Clicked Images; nothing at all, no reaction
Clicked Videos; worked as expected
Clicked Images; now Chrome is clocking but nothing happens for a while after that eventually, I get the ERR_HTTP2_PROTOCOL_ERROR message

On the DuckDuckGo page, entered my random noun; clicked Images and got lots of pictures back, as expected

In AdGuard, turned off the Base Filter (Settings / Ad Blocker / Ad Blocking / AdGuard Base filter checkbox); I tried this because of something I read somewhere in Reddit (I think?)

In Chrome hit <Ctrl-E> and entered a random noun into the search area; successful retrieval of the images page

In AdGuard, turned the Base Filter back on

In Chrome hit <Ctrl-E> and entered a random noun into the search area; successful retrieval of the images page; huh...

Rebooted the laptop; this may be a key step that I have NOT been consistently doing and now my prior results are all suspect, so I will be more careful now.

In Chrome hit <Ctrl-E> and entered a random noun into the search area; nothing

So I definitely needed that reboot...!

From @H3lper, "What if you disable Web Protection in MalwareBytes? I've seen a few users with the same issue, one of them had to disable AV\Firewall software to get it working."

I decided to turn EVERYTHING off in Malwarebytes and start from scratch; I turned off all four items - Web, Malware, Ransomware and Exploit Protection
I'm leaving Bitdefender active, though

Rebooted the laptop

In Chrome hit <Ctrl-E> and entered a random noun into the search area; nothing

From @Boo Berry, "There's also one other thing you could try, go into AG for Windows' Settings and in the General section scroll down and click on Advanced Settings. In Advanced Settings scroll down to the Use redirect driver mode option which by default it should be unchecked. Try checking this box and press the green Save button and reboot your PC and see if that makes any difference."

In AdGuard, turned on "Use redirect driver"

Rebooted the laptop

In Chrome, hit <Ctrl-E> and entered a random noun into the search area; successful retrieval of the images page!!!

Now I want to make sure this change was it. I'm going to turn Malwarebytes back on and reboot and test. Then I'm going to uncheck "Use redirect driver" and reboot and test.

In Malwarebytes, I turned ON all four items - Web, Malware, Ransomware and Exploit Protection

Rebooted the laptop

In Chrome, hit <Ctrl-E> and entered a random noun into the search area; successful retrieval of the images page

In AdGuard, turned OFF "Use redirect driver"

Rebooted the laptop

In Chrome, hit <Ctrl-E> and entered a random noun into the search area; nothing

Conclusion:

Two things seem give me back Images in Google search.

1. Turn off the AdGuard Base Filter
2. Turn on "Use redirect driver"

What does this suggest? Apologies, I have no technical knowledge here.

Also, how could this have changed? I had no issues with Google search and Images before.

Thank you all,
Rob
 

CeeTee

New Member
@kavabanga

Installed and tried the current nightly - made no difference - still encountering http2 errors when using 'Images' option of Google Search - also encountering http2 errors when uploading images to services such as CMS back-ends.

FWIW - I am not running Kaspersky A/V and get the same issue on a system running just Windows Defender.
 
Top