[Closed] Performance ....

Discussion in 'Technical Support (AdGuard for Windows)' started by der_Kief, Mar 25, 2019.

  1. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,431
    @der_Kief

    This is a good start.

    If you add AdGuard.exe and AdGurdSvc to the exclusion list and check?
     
  2. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,431
    @der_Kief

    If it would be possible for you to let me check the settings directly via TeamViewer? For details, you can send it to me in PM.
     
  3. der_Kief

    der_Kief New Member

    Joined:
    Nov 20, 2018
    Messages:
    23
    Doesnt help ....

    Since updating to latest nightly i have a new problem now. Every once in a while AdGuard crashes.
    I just send an automatic error report with an comment / hint to this thread.
    Maybe this is helpfull

    If its really necessary than it has to wait till weekend because atm i'm only infrequent at my PC.
     
  4. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,431
    @der_Kief

    Yes, all crash reports are very important and all of them will be investigated by our devs. Reply back to me when you'll be ready.
     
  5. Steven Shank

    Steven Shank New Member

    Joined:
    Feb 5, 2019
    Messages:
    10
    I'm sorry if I missed this, but did you turn off the AVAST SSL filtering. Having 2 vpn/proxy servers/ Man in middle/ programs is a possible issue.
     
  6. der_Kief

    der_Kief New Member

    Joined:
    Nov 20, 2018
    Messages:
    23
    @Steven Shank
    yes i already tried that but doesn't solve the issue. Only working solution atm is to completely deactivate Avast.
    As this is no option for me i'm using my approved ublock variant atm.
    Hopefully this get fixed soon ... but as i use my PC not often atm its not really critical for me.
    But nevertheless i'm waiting for a solution ;)
     
  7. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,214
    You might try the latest nightly build, as there was a fix for the ESET incompatibility. Maybe it'll also fix the Avast one?

    EDIT: @avatar mentioned in the Telegram chat the ESET incompatibility fix should work for other AVs as well because the underlying issue was because AG didn't "trust" antivirus apps' certificates. So it should work for other AVs besides ESET and might work for Avast as well. :)
     
  8. der_Kief

    der_Kief New Member

    Joined:
    Nov 20, 2018
    Messages:
    23
    new nightly update is awesome :D

    - fixes random chrashes
    - fixes err_ssl_version_interference issue
    - improved speed (reduced delay) but still behind ublock addon for Chrome solution

    All in all this update is perfect but hopefully speed resp. delay can be optimized even more ;)
     
  9. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,214
    @avatar said in the Telegram chat that there are known issues with the current nightly builds that do impact performance but they haven't yet tackled them, as they wanted to deal with the crashes and the ESET (well, AVs in general) incompatibility. He said it's easy to notice on websites loading lots of little images over HTTP/1.1. But, at least they'll get to it. :)
     
  10. der_Kief

    der_Kief New Member

    Joined:
    Nov 20, 2018
    Messages:
    23
    @Boo Berry
    that's good to know :)

    Is there a kind of changelog for the nightly builds ?
     
  11. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,214
    Try the newest nightly that was just released, it's suppose to contain a performance fix for the WFP driver. Hopefully this fully fixes this issue. :)

    For me, performance has DEFINITELY increased when using the WFP driver.
     
  12. philibeur

    philibeur Beta Tester

    Joined:
    Mar 6, 2019
    Messages:
    19
    Indeed, for my part too, I have better performance, thank you for the work upstream!
     
  13. ram1220

    ram1220 New Member

    Joined:
    Sep 26, 2015
    Messages:
    71
    I have noticed a slowdown in browsing over the past few days. Nothing has changed on my computer. Yesterday I decided to try the nightly updates. The slow down was fixed all afternoon. But in the evening I rebooted my computer and Adguard refused to run. I couldn't do anything with it. It wouldn't even let me sent crash logs to Adguard. I then unchecked the box to send the logs and I was able to send support a request. But I went ahead and uninstalled Adguard because there wasn't anyway to switch back to the regular stable version since Adguard just sat there trying to start. The settings tab was greyed out. I reinstalled the regular stable version and Adguard is running fine. Although my slow browsing is back again today. I will say that after uninstalling Adguard I went out on the internet and my computer was back to its fast self. But I hated the ads so I went back to regular Adguard. Something isn't right with Adguard and is causing internet slowness. This is the first major issue that I have had with Adguard in years. I did try to disable WFP driver setting but it made no difference.
     
  14. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,214
    6.4 suffers from the WFP performance issues. As for the inability to have the nightly builds run, I'd contact @TheHasagi about that one to see if he can help!
     
  15. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,431
    @ram1220

    Hello there,

    Can you tell me the version (Nightly) you are using? Also, what filters are enabled? Browser version and what websites?
     
  16. ram1220

    ram1220 New Member

    Joined:
    Sep 26, 2015
    Messages:
    71
    I uninstalled the nightly. I'm back on 6.4 which has slowed my internet usage quite a bit. I believe the nightly that locked up on me and wouldn't run said 7.0 at the top. Firefox browser 66.0.3. And it was on all websites I tried. Like I said earlier in the day I was using the nightly before it failed on me and my internet was fast. I don't know what filters I had turned on. Sorry. Uverse 100/100 fiber internet.
     
  17. ram1220

    ram1220 New Member

    Joined:
    Sep 26, 2015
    Messages:
    71
    Ok I just turned off the WFP driver in 6.4 and my internet is fast again. However I am now seeing ads on Youtube and a few other sites. This is unacceptable since I pay Adguard so I don't have to see ads. I would go back to the nightly but I am afraid it will fail on me again and I'd be stuck uninstalling and reinstalling Adguard once again. Are there any plans to fix WFP filtering? Can I roll back to a previous version?
     
  18. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,214
    The WFP filter performance issue(s) will be fixed in AG for Windows 7, which is what the nightly build is. But it's likely at least several more months before it even reaches the stable channel (and replaces 6.4). You shouldn't see ads with the TDI driver (the fallback driver when WFP is disabled) unless you're using Microsoft Edge, which requires the WFP driver to use though you mentioned using Firefox. There's been reports of YouTube ads appearing regardless, and it might be related to Google embedding ads into videos (using the same domain(s) they use to serve video content) making those ads "unblockable" without breaking the videos themselves. Time will tell on this one though.
     
  19. ram1220

    ram1220 New Member

    Joined:
    Sep 26, 2015
    Messages:
    71
    I was just able to switch back to nightly. It says version 7.0. Browsing speed is now back again. Not sure why the nightly cause Adguard to fail last night but as of right now it is working again. Thanks for the help!
     
    Last edited: Apr 15, 2019
  20. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,431
    @ram1220

    Since the Nightly builds are quite unstable sometimes, we are working on to fix the issues with WFP/TDI and speed dropdowns. Please, stand by for the updates.