Disqus comments not always loading


New Member
I see a lot of threads on blocking Disqus, but I'd like to do the opposite. On some sites, it works just fine. However, sites like CarScoops.com, I can only see the comments on an article if I turn off Adguard.

I've tried adding disqus.com in the allowlist, but that didn't help.

I'm using the browser plugin. I see the same issue in both Firefox and Chrome.

Thank you.


New Member
Good question:
Ad Blocking
- AdGuard Base filter
Social Widgets
- Adguard Social Media filter
- Filter unblocking search ads and self-promotion
- AdGuard French filter
- AdGuard Russian filter
- AdGuard German filter
- AdGuard Dutch filter
-EasyList Czech and Slovak
- EasyList Italy
- Estonian List


New Member
Turned off everything but the base filter. Restarted. Same problem (both Firefox and Chrome). Stealth Mode is disabled.

Interesting that it works for you. I followed the link you posted and didn't see the comments.


New Member
In Chome, as I scroll down to where the comments are, Disqus flashes briefly then goes away.


New Member
I've experimented and it seems the issue is in "Adguard Base filter" and Easylist." When I turned them off on my phone or my PC it will show Disqus, but a new problem arises where it isn't blocking some ads, as well as, whatever element cause a pop up when you clock on a page, I have tried to unblock in the rules but there has been no changes at all.


New Member
Updating this one so I don't post a 3rd, the rule did not work at all, I have gone through the filter logs to try to remove the rules individually and it's still refusing to unblock disqus, so the options are to use the base filter and have no disqus or turn it off and have other things slip through
Last edited:


New Member

This is exactly my problem too. I am coming from uBO and trying to figure out how to convert my user rules to Adguard, particularly my thirdparty-noop rules. Disqus is one of many that I would like to allow.

The others, such as Paypal.com, I would like to allow only on particular first-party sites, like ebay.com.

Here is an example of my uBO list that I need to convert. At the top, of course, are Adguard allow rules. The bottom rules are the uBlock rules I need to import:


* amazonaws.com * noop
* disqus.com * noop
* disquscdn.com * noop
* dwcdn.net * noop
* translate.google.com * noop
* googleapis.com * noop

amazon.com akamaihd.net * noop
amazon.com media-amazon.com * noop
aws.amazon.com awsstatic.com * noop
amazon.de amazon.com * noop
androidauthority.com androidauthority.net * noop

Thanks in advance for any help.


New Member
Use case: I am currently using both Adguard and uBO because, frankly Adguard just blocks ads better, even with the same lists enabled (especially Youtube.) But uBO is better for advanced filtering of third parties, and for general unknown script blocking. I like the button I can click to modify my custom rules. It's also easier to quickly disable a filter, or even all cosmetic filters, while leaving generic filters enabled. I only enable well-known adblock and annoyance filters in Adguard.

So I'm using uBO for generic filtering, and for special-case-filters that I can quickly disable. When there's a problem with a site I first disable uBO's cosmetic filters. 2nd, I disable uBO completely, and finally I try Adguard. If it's a favorite site, I can drill down into the problem extension and find the culprit. Normally, though, I just move on and let uBlock erase my changes because I probably won't visit that site again.

The problems I'm digging into are the third-party elements that come up on many sites... such as Disqus comments not showing. Unfortunately Disqus is usually used on sites with lots of ads and trackers -- sites where I really need Adguard because uBO just doesn't cut it. So I'd love to figure out how to un-exclude Disqus from it all together.


Filters Developer
Staff member
Hi. Is the problem related to enabled filters, stealth mode, user rules or to uBO?