DNS (noob) question

Discussion in 'Discussion (AdGuard for Android)' started by Rogue Sero, Apr 14, 2019.

  1. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    (please forgive me. This is a copy / paste of my question on Reddit. I just figured it might be better to ask here)

    So, since I got my Pixel 3 XL about 2 weeks ago, Internet with Adguard Pro on is painfully slow. Like really really slow. Most notably in Chrome and Instagram.

    I never had this issue on my Pixel 2 XL. Everything was working great with normal, fast internet. So no clue what the difference is between the devices.

    Today , in Apps Management, I found an (system) 'app' simply called ''DNS''. I turned it off for Adguard. (flipped the Adguard protection switch for the 'app').

    And now it seems, all is working fast again.

    I still use Adguards DNS in the main settings, though.

    Now I just wonder if I did a good thing. What exactly happened ? And should I keep it this way ?

    (I so hope I am making sense, lol)
     
  2. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    Thanks everyone. Really appreciated ! :(
     
  3. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,852
  4. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,414
    @Rogue Sero

    Hello!

    Can you go back to the default settings and just try changing the DNS server type from DoH to DoT/Crypt/Regular and check again?
     
    Rogue Sero likes this.
  5. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    Hi,
    You mean 'reset' the whole app Adguard ?
    And how / where do I change to DoT/Crypt/Regular ?

    I'm sorry, I truly am a noob when it comes to this. All I remember is everything working great on my Pixel 2 XL, whichever settings I used.
    And on the 3 XL Internet is so so slow with Adguard enabled :(
     
  6. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,414
    @Rogue Sero

    It's ok :) Open AdGuard - Apps management - 3 dots - Reset settings, then go to AdGuard - Settings - DNS Filtering - Choose AdGuard or Google DNS then find the option named as server type:
    [​IMG]

    Try with all types and check :)
     
    Rogue Sero likes this.
  7. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16

    Thank you so so much fro your help.

    Give me a day or two to test these :)
     
    TheHasagi likes this.
  8. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    I did. And I saw no change :/
     
  9. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    Ok. It's getting truly annoying now.

    With Adguard off - No problems
    With Adguard enabled - Super slow connections

    EDIT:
    Ok. Seems disabling the VPN system app had a placebo effect on me, because I feel it doesn't really help after all.

    Also, the main culprit is probably the 'Local VPN' setting. As when I change it to 'Local HTTP proxy', I get normal internet again. But a bit useless, because it restricts the firewall functions :/
     
    Last edited: Apr 21, 2019
  10. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    So wheres the best place to get help ?
    Because this place is dead
     
  11. Chinaski

    Chinaski Support Marine Staff Member Administrator Moderator

    Joined:
    Apr 15, 2019
    Messages:
    363
    @RogerNadal

    Hello!

    Please specify which browser you are using. Do not you have an application with the VPN function?

    Try to check if these two parameters are set to true in AdGuard - Settings - Advanced - low-level settings - pref.vpn.disable.reconfigure/pause
     
  12. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16

    Hello.
    Thank you so so much for your reply.

    I have checked the two parameters and they are switched on :)

    But, just today I also had a response on Reddit.
    This person said I should go to
    Android Settings > Network & Internet > Advanced > Private DNS > Off > Save
    And restart my phone.

    I have done this , and so far my internet is fast again !

    I will have to see if this lasts and if this really is the solution, but so far so good.
    I am so so happy now !!

    This might have been the issue. It seems this is a new feature in Android Pie.
     
  13. Chinaski

    Chinaski Support Marine Staff Member Administrator Moderator

    Joined:
    Apr 15, 2019
    Messages:
    363
    We are glad that the problem was solved.
    Thank you for the request. Always happy to help!
     
    Rogue Sero likes this.
  14. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    Sadly, the solution did not last. And connections got very slow again after some time :/
    I am so sorry. I have now switched to Blokada. Hoping it will work better for me.

    I will not, however give up on Adguard, mainly also because I have paid for a lifetime license.
     
  15. Chinaski

    Chinaski Support Marine Staff Member Administrator Moderator

    Joined:
    Apr 15, 2019
    Messages:
    363
    @Rogue Sero

    Can you clarify what filters are you using? Try to leave only those that are marked with a star. (AdGuard recommendation)
    (Settings > Content Blocking > Filters)
    And set a High-Quality filtering method - OFF
     
    Last edited: Apr 24, 2019
    Rogue Sero likes this.
  16. Chinaski

    Chinaski Support Marine Staff Member Administrator Moderator

    Joined:
    Apr 15, 2019
    Messages:
    363
    Also, specify do you use applications like antiviruses?
     
  17. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    I do not.
    I did however use one on the Pixel 2 XL. And on that device I never had any trouble with Adguard.

    Thanks ! I have only been using Aguard in the default state last few days.
    I have tried many fresh installs.

    Usually after half a day, the connections slow to a crawl. Most notable in Chrome (-Dev / Beta). Instagram (but I usually disable the firewall for Insta). Twitter. Relay pro (Reddit reader). And some games that use cloud save.
    Some other apps, like Whatsapp, Gmail and Bluemail seem unaffected.

    I'm sorry. I really appreciate all the help, but I am a bit done testing for now. So far Blokada is doing a great job, so I will leave it like this for a while.

    If it is okay, I would like to come back to this issue at a later time. maybe when some new updates have past.

    :)
     
    Last edited: Apr 24, 2019
  18. BACILIYATSIA

    BACILIYATSIA New Member

    Joined:
    Apr 5, 2019
    Messages:
    26
    Today , in Apps Management, I found an (system) 'app' simply called ''DNS''. I turned it off for Adguard. (flipped the Adguard protection switch for the 'app').

    And now it seems, all is working fast again.

    I still use Adguards DNS in the main settings, though.
     
    Last edited: May 15, 2019
  19. Rogue Sero

    Rogue Sero New Member

    Joined:
    Apr 14, 2019
    Messages:
    16
    ???