DNS-Problem mit 4.3.1

Heinz Werner

New Member
Hallo,

ich habe ein merkwuerdiges und kompliziert zu beschreibendes DNS-Problem mit Adguard Pro Version 4.3.1 und iOS 15.2 auf einem iPhone 12 pro.

Ich nutze auf dem iPhone zusaetzlich noch eine App um auf meinen Desktop-Rechner auf Dateiebene (Windows 10) via WLAN zuzugreifen.
Die App heisst "Filebrowser Pro".

Nun zum Problem:
Auf dem Desktop-Rechner (Windows) sind Ordner mit MP4-Dateien.
Bisher (bis Adguard-Version 4.2.2 und Beta 4.3.0(915) ) funktionierte das auch seit Jahren einwandfrei.

Ab Version 4.3.1 funktioniert das nicht mehr einwandfrei.


Wenn ich Adguard Pro Version 4.3.1 installiere koennen beim ersten (!) Zugriff via Filebrowser Pro die MP4-Dateien nicht abgespielt werden.
(Ich bekomme eine Meldung: Verbindung zum Server konnte nicht hergestellt werden)
Erst nach einem schliessen der App Filebrowser Pro und einem erneuten Zugriff auf den Windows-Ordner mit den MP4-Dteien koennen die Videos abgespielt werden.

Wenn ich den Filebrowser schliesse und warte ein paar Minuten, funktioniert es wieder nicht.

Temporaere Loesung:
Ich kann in Adguard Pro 4.3.1 (DNS-Schutz - DNS-Filterung - Freigabeliste) die IP meines Windows-Rechners eintragen.
Dann funktioniert der Zugriff auf die MP4-Dateien einwandfrei. Jederzeit.

Allerdings nur, bis das iPhone neugestartet wird. :(

Nach dem Neutstart des iPhones ist der Eintrag mit der IP des Windows-Rechners nicht mehr vorhanden.

Er muss neu eingetragen werden. Danach funktioniert der Zugriff wieder, allerdings nur bis zum naechsten Neustart des iPhones.
Dann fehlt der Eintrag wieder.
Das ist ein schlechter Zustand.

Alternativ kann ich ein Downgrade auf die Beta-Version von Adguard Pro mit der Version 4.3.0(915) machen.
Damit funktioniert alles einwandfrei. Auch ohne den Eintrag der IP in die Freigabeliste.

So hat das auch seit Jahren funktioniert.

Nur seit der Version 4.3.1 funktioniert es nicht mehr richtig.

Gruss
Heinz
 
Top