DuckDuckGo & YouTube

Morku

New Member
@Chinaski
Actually, it's difficult to reproduce the issue, because it seems very sporadic to me. But it's definitively still there.
Yesterday, I waited hours and all was fine. I had Youtube and DuckDuckGo open, waited minutes/hours -> nothing
I closed the tab and waited hours -> nothing
I closed Firefox for a while, reopen it -> all fine
I rebooted the PC multiple times -> all fine

For one moment I thought, maybe I was wrong and it is fixed.

Today, the issue occured again twice. What I can say is -> When it happen, my Youtube Subscription Tab was still open with the old YouTube Layout. I loaded Youtube in another tab -> Layout Cookie got cleaned and I have the new Layout back.
Also the settings in DuckDuckGo were gone again.

If you don't know what I am talking about: I am using this Script to have the old YouTube Layout: https://greasyfork.org/de/scripts/32906-get-me-old-youtube
You activate the Script -> get the old Layout and than you disable it, because all necessary information are stored in a Cookie so that always the old Layout is loaded. You don't need the Script anymore.
With Stealth Mode enabled in AdGuard, this Cookie gets cleaned after a while. Interestingly, not your Login information, so you are still in your YouTube Account.

What I can also say for sure, adding this custom filter bypass the bug for sure. I had weeks with AdGuard 7.0 and days with 7.1 without any cleaning issue anymore:
Code:
@@||youtube.com^$stealth
@@||duckduckgo.com^$stealth
Providing a Debug Log seems to be difficult to me, if I am unable to find out how to reproduce. How much sensitive are these information? My whole browsing history during that time?
 

Boo Berry

Moderator + Beta Tester
Moderator
What Stealth Mode settings are you currently using (so reproducing this can be attempted easier)?
 

Morku

New Member
@Boo Berry
This are the settings. I will reenable the the Debug Logging, remove the custome filters and wait for the moment and export it.
Code:
Stealth Mode enabled: StealthModeSettings: {
  "BlockThirdPartyCookies": true,
  "BlockThirdPartyCookiesPeriodMin": 180,
  "BlockFirstPartyCookies": false,
  "BlockFirstPartyCookiesMin": 4320,
  "DisableThirdPartyCache": false,
  "BlockWebRtc": false,
  "BlockBrowserPushApi": false,
  "BlockBrowserLocationApi": false,
  "BlockBrowserFlash": false,
  "BlockBrowserJava": false,
  "RemoveXClientDataHeader": true,
  "StripUrl": true,
  "HideSearchQueries": true,
  "SendDoNotTrackHeader": true,
  "RemoveReferrerFromThirdPartyRequests": false,
  "HideUserAgent": false,
  "CustomUserAgent": null,
  "CustomReferrer": null,
  "HideIp": false,
  "CustomIp": "209.141.53.254",
  "BlockThirdPartyAuthorization": false,
  "StrippedUrlParameters": [
    "utm_source",
    "utm_medium",
    "utm_term",
    "utm_content",
    "utm_campaign",
    "utm_referrer",
    "yclid",
    "gclid",
    "fbclid",
    "_openstat",
    "fb_action_ids",
    "fb_comment_id",
    "fb_action_types",
    "fb_ref",
    "fb_source",
    "action_object_map",
    "action_type_map",
    "action_ref_map"
  ]
}
 

Morku

New Member
I came home, started my PC, loaded YouTube aaand it already got cleaned.
@Chinaski @Boo Berry
You will get the Logs in PM. I hope you'll find the reason. If any other information or test is necessary, just tell me.
 

Morku

New Member
Hi,
Adguard Nightly still offer 7.1.2848 which contains CL 1.4.78
Github says it is fixed in CL 1.5. I guess I have to wait first for new Nightly?
 

Morku

New Member
sfionov commented 3 days ago
Of course he still had the issue, because there was no new nightly release since it was marked as fixed 5 days ago.

7.1.2848 is out since ~8th july = way more than 5 days.

Today I received update 7.1.2861 with CL 1.4.91. The Changelog preview shows that it includes the fix.

So I removed the custom filter for DuckDuckGo and Youtube again and I'll see if the Cookies still get cleaned.
I can say for sure in 1-2 days.

EDIT: Uh, nevermind, just noticed he refer to my post :D
 
Last edited:

Morku

New Member
Bad news, with 7.1.2866 they got cleaned again :(
I go for custom filters again...
(and start of Kee AddOn is still heavily delayed)
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
Please disable the specified function. Perhaps the problem is reproduced when it is turned on.
upload_2019-7-22_14-11-42.png
 

Morku

New Member
4 days pased since I disabled self-destruction of third-party cookies and removed the userfilters again. (Now on 7.1.2872)

No cleaning yet. I would say: Disable this feature solved the issue.

But you guys are sure that this is working as expected? Do Youtube and DuckDuckGo make use of a third-party cookie to save usersettings? And why the issue occur mostly after a day, not every 180 minutes?
Also, my browser not accept third-party cookies. So if this is because of third-party cookie, the settings shouldn't be saved at all. I still wonder...
 

Morku

New Member
2 days passed since I activated back the Third party cookie cleaning. This option was not the cause.

Still no issue. So yes, it's finally solved with CoreLibs 1.4.120.

Thank you for having all the patience with me and having a deeper look.
 

Toto

New Member
Hello guys,

I was on vacation in july and I'm back again. I have tested AdGuard 7.1.2817 final version since 1st august and the problem doesn't appear. It works like a charm now :)

Great job AdGuard ;)
 
Top