Edge extension ads huge style section to mail service site...

Discussion in 'AdGuard for Edge' started by JohnB, Sep 11, 2017.

  1. JohnB

    JohnB New Member

    Joined:
    Sep 11, 2017
    Messages:
    2
    I work with AWeber.com to send emails to a couple of non-profit groups. I switched to Edge (after Chrome issues I can't resolve) and just added Adguard some weeks since my last email.

    I suspect it's common sense to disable Adguard for a site where you are creating html, but I do a little of so many things I wasn't alert.

    Anyway, in AWeber copying and editing an old email with new content I found in the Source view that some 12,000 lines of code were being added in the Style section of the header. It was all referring to Adguard. It went out fine if slowly to gmail and yahoo for test, but when I cut it out of my draft and resaved, it came back.

    Anyway, I disabled filtering for that site and it stopped appearing.

    I assume this happens in (some?) in-browser html editors. Is it happening here, in this message?
    I trust it's something you want to know about. A short selection is attached (full txt file 2MB).

    JohnB
     

    Attached Files:

  2. Blaz

    Blaz Moderator & Translator Moderator

    Joined:
    Dec 21, 2014
    Messages:
    7,623
    Looks like expected behaviour to me when it is adding styles or else it can't hide elements.

    Try one of the following rules:
    @@||aweber.com^$elemhide
    @@||aweber.com$document

    If it is a different url, change aweber.com to its url.
     
  3. JohnB

    JohnB New Member

    Joined:
    Sep 11, 2017
    Messages:
    2
    Blaz, thank you. I'm not sure I was clear enough.
    I'm referring to a mass-mail creation site. I should have shut off Adguard on a site like that, but I thought it was worth posting that the Adguard code (what it inserts into any page it is guarding) was inserted also into the source code of the new email I was creating there.
    I was using a rich text editor very much like the one I'm using now.
    Again, thanks for the followup.