ESPN (Radio) Stops Playing

LeatherNeck

New Member
Good Evening All,

Happy user of AdGuard here.

Just wanted to report that when using the ESPN app and while listening to either live radio or a podcast, whenever they go to a commercial break the audio always stops playing.

If I disable AdGruard for the app the audio continues to play just fine.

I haven't changed any settings within AdGuard, and don't run any other apps that would interfere with it

Any help would be greatly appreciated, since I pretty much use this app daily to listen to the radio/podcasts.

Phone:
Nexus 6P
Android 7.1.1
 

Blaz

Moderator & Translator
Staff member
Moderator
Please list your Adguard filters and provide an url to the app itself, if possible.
 

LeatherNeck

New Member

vasily_bagirov

Administrator
Staff member
Administrator
@LeatherNeck Hi! I assume the skipped part is ads? I mean, in that case, it looks like Adguard works as intended. If any useful content is blocked instead, please post this to the 'False positives' subforum according to submission rules.

Or maybe I interpret your words incorrectly and the audio stops altogether and doesn't come back when the commercial is over?
 

LeatherNeck

New Member
@LeatherNeck Hi! I assume the skipped part is ads? I mean, in that case, it looks like Adguard works as intended. If any useful content is blocked instead, please post this to the 'False positives' subforum according to submission rules.

Or maybe I interpret your words incorrectly and the audio stops altogether and doesn't come back when the commercial is over?
My apologies, I should have been more specific with the issue.

Yes, the audio stops on commercial break (as intended and desired), but fails to restart when commercials are over.
 

seanl

Well-Known Member
@LeatherNeck Hi, is there any particular podcast that has a commercial break at a predictable time, or should it occur rather randomly while playing podcasts? Any information would be helpful in reproducing the issue. I tried playing a podcast for 40 mins, but couldn't reproduce the issue.
 
Last edited:

LeatherNeck

New Member
@LeatherNeck Hi, is there any particular podcast that has a commercial break at a predictable time, or should it occur rather randomly while playing podcasts? Any information would be helpful in reproducing the issue.
While listening to a live radio show, whenever they go to commercial\ad break the audio completely stops. If you try to hit the "play" button I get what is shown on the attached screenshot.

I just tried a podcast, but couldn't reproduce the issue either, which now that I think about it kinda makes sense if it's just a recording. I found a couple ads in the Mike&Mike Podcast, but the audio never stopped so I was mistaken about podcasts.

The issue for me only applies to live streaming radio with AdGuard fully enabled and when they go to commercial break.

I just spent the better part of 30-40 minutes reproducing this issue, and trying different options.
  • If the "Route app traffic through Adguard" under "App Management" for this app is checked then I couldn't get any audio to play at all when selecting "listen live" after fresh boot of the phone.
    • I made sure on my computer it wasn't commercial break.
    • This usually isn't the case, and I can normally play a show for first time just fine when not commercial break.
  • If I uncheck the above box I would have to restart my phone, or force stop & clear cache in order for the audio to start playing again when selecting "listen live". Commercials would play and nothing stopped.
    • When re-checking this box, everything continued to play normally, even commercials. When I force stopped/cleared cache is when it would stop playing.
  • I'm not sure if it's the hour of the night that my issues are a little different than normal, and the fact that their ads at night maybe are less.
  • I will verify again tomorrow during the show I normally listen to that starts @ 9am, and since I think I have confused the hell out of myself trying different options. The morning shows are very consistent with commercial breaks.
I hope some of this makes sense, and thanks again.
 

Attachments

avatar

Administrator
Staff member
Administrator
@seanl if you cannot reproduce the issue, we might need to ask @LeatherNeck to record a HAR file.

Or try it yourself, maybe there's a pattern you can see even without ads?
 

LeatherNeck

New Member
Successful reproduction of issue just now listening to live stream of The Dan Lebatard show.

ESPN was enabled in adguard, stream started playing normal as they were in middle of a segment, as soon as segment ended and commercial started the stream stopped and trying to play gave me toast msg in my previous screenshot.

Disabled espn in AG, went back to it hit play and it started playing the commercial.

Not sure what a HAR file is, but I'll do whatever might help.
 

seanl

Well-Known Member
Actually it may not be needed, because I was able to reproduce the issue and investigate on my side :)
I will request when it is needed.
 
Top