Failed to install Adguard cert for HTTPS Filtering (Android 11)


New Member
Hi all. I followed the steps given to install Adguard cert:

  1. Open Device settings
  2. Go to 'Security'
  3. Go to 'Encryption & Credentials'
  4. Go to 'Install from storage' or 'Install a certificate' (depend on devices)
  5. Select 'CA Certificate' from the list of types available
  6. Accept a warning alert and click "install anyway"

Only up till this step, it didn't direct me to the page where I saved my cert. It stayed on the page of step 5 above.

When I tried to proceed from step 5 to step 6 again, it prompted an error message "Certificate Installer keeps stopping". I had to click "Close App" at this point.

Note: I've tried to force stop "Certificate Installer"; also I deleted Adguard and reinstalled the latest version; deleted all my PIN and fingerprint and reset; deleted all other previously installed Adguard cert; restarted my phone, but to no avail.

What's the issue??

edit: typo
Last edited: