Filter https protocol breaking Firefox

Discussion in 'Technical Support (Adguard for Mac)' started by jslawler, May 18, 2017 at 2:05 PM.

  1. jslawler

    jslawler Beta Tester

    Joined:
    Oct 28, 2016
    Messages:
    2
    Hi there,

    I am experiencing the following:

    Adguard - Filter https protocol preventing Firefox from establishing a connection to any url, displaying "Your connection is not secure".

    Adguard: 1.4.1
    Firefox: 53.0.2 (64-bit)

    Any ideas?
     
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,804
    Yeah, sounds like the Adguard certificate didn't import to Firefox. Usually rebooting the Mac will take care of it (and Adguard *should* install the needed certificate).

    You might be able to do this too: close Firefox completely (make sure it's not running in the dock) go into Adguard's settings to the Network section, uncheck Filter https protocol then recheck it. That might also install the needed certificate into Firefox. Sadly, Adguard for Mac lacks the Reinstall Certificate button Adguard for Windows has (@vasily_bagirov this should be added as a request, IMO).
     
  3. jslawler

    jslawler Beta Tester

    Joined:
    Oct 28, 2016
    Messages:
    2
    Thanks Boo Berry,

    Don't listen to anyone mate, you're not just a pretty face! Restarting it fixed the issue and the certificate was able to be applied.
     
  4. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    5,824
    @Boo Berry @jslawler

    This is exactly the reason we opted for not adding such button for Adguard for Mac. It felt excessive.