Firefox crashing, Tab corruption

Discussion in 'Technical Support (AdGuard for Windows)' started by MC Fat Tongue, Feb 3, 2015.

Tags:
  1. MC Fat Tongue

    MC Fat Tongue New Member

    Joined:
    Jan 24, 2015
    Messages:
    13
    Hello all,

    I have encountered a couple of problems while using Adguard and Firefox.

    I use gmail, I can login as normal I have never had a problem with that, but when I logged in recently gmail asked me to verify my account. It does this occasionally if it thinks there has been unusual activity on the account. To verify my gmail account it asked me to enter my mobile phone number which I did, but when I click on the button to send them my number Firefox crashed. I cleared my cache and restarted Firefox and tried again (3 times) but it crashed on each attempt.

    Once I had disabled protection and closed Adguard I entered my mobile number on my gmail account and this time it worked perfectly. I suspect it has something to do with the fact that "Filter HTTPS Protocol" is on but I am only guessing. I was using the default driver but have changed it to the WFP one to see if it makes any difference.

    One other thing I have noticed is sometimes when I have multiple tabs open in Firefox and I close one of them, the window for that tab closes as normal but the actual tab button remains and is corrupted, the button will clear on its own but will take several seconds (10+) to disappear. This is only an intermittent fault and may occur only a couple of time a day. I'm not sure if this is Adguard related or not but I have mentioned it because it has only been happening since I installed Adguard.

    My setup:

    Windows 7 (64bit)
    Firefox 35.0.1
    Adguard 5.10.1190.6188

    Adguard filter lists:
    English Filters
    Spyware Filters
    Social Media
    Easy Privacy
    Fanboy Annoyances
    Fanboy Enhanced Tracking List
    Malware Domains
    Spam 404

    Adguard Extensions:
    Adguard Assistant
    Adguard Popup Blocker
    Web of Trust

    Any help or assistance would be greatly appreciated.

    Edit: I have had to go back to using the TDI instead of the WFP driver because on ebay.co.uk searches were taking forever (refreshing for a long time) searches are almost instant with the TDI driver. General browsing with WFP was sluggish.
     
    Last edited by a moderator: Feb 3, 2015
  2. MC Fat Tongue

    MC Fat Tongue New Member

    Joined:
    Jan 24, 2015
    Messages:
    13
    I've found-out a little more about the tab corruptions in firefox, I think it is definitely cause by Adguard.

    When a tab is closed and the tab button (header) corrupts, the window rightly closes, but while the corruption exists clicking in the window of any other tab that is left corrupts that window at the point where the mouse pointer is clicked.

    The reason I say I know it's Adguard causing this is because when the corruption occurs, if I left click the mouse pointer on the Adguard shield in the system tray, the corruption is corrected instantly.

    Filter https protocol is turn on.
    The corruption occurs with both the TDI and WFP drivers.

    ---------- Post added at 05:00 AM ---------- Previous post was at 04:05 AM ----------

    I have still more info.

    Again gmail asked me to verify my identity on my email account, and again when I tried to enter my mobile number Firefox crashed.

    So this time in Adguard I turned off Filter https protocol and tried again, but it crashed firefox, I then turned it back on. I then kept retrying to verify my gmail account, but this time I deactivated a different one of my filter list on each try. When I had deactivated Easy privacy I was able to verify my gmail account. It seems as though one of the filters in Easy Privacy is not reacting very well to my system.
     
    Last edited by a moderator: Feb 4, 2015
  3. mysteriously

    mysteriously Beta Tester & Translator

    Joined:
    May 4, 2014
    Messages:
    508
    Do you have any FireFox extensions installed?
     
  4. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,900
    If you are sure that the problem is caused by EasyPrivacy list, then I'm afraid there is not much we can do. The list is just imported to Adguard, we don't own it and can't change it.

    Concerning corrupted tabs: does this problem occur only with multiple tabs open? Maybe you spotted any other coincidences or is it completely random?
     
  5. MC Fat Tongue

    MC Fat Tongue New Member

    Joined:
    Jan 24, 2015
    Messages:
    13
    Vasily,

    The tab corruption seems to occur with two or more tabs open, but it seems to sometimes corrupt the tab (header) now even when I'm not closing a tab. Before I had to wait 10+ seconds for the corruption to clear, but I've discovered that clicking on the Adguard green shield icon in the notification area (bottom right) clears the corruption straight away.

    I have deleted the EasyPrivacy filter list from Adguard and so far no Firefox crashes.

    Vasily, would you please be kind enough to take a look at the filters lists I posted in my first post, and tell me If you think I should remove any of them. for example does the Fanboy Annoyances list do basically the same job as the Social Media list, what I am trying to do is delete any of the lists that basically do the same or a similar job to another list.

    buuuuuuu190,

    My Firefox addons are:

    Kaspersky Dangerous Websites Blocker
    HTTPS-Everywhere
    LastPass
    Myibidder (Myibay) Bid Sniper for eBay
    NoScript
    Open Bookmarks in New Tab
    Privacy Badger Firefox
    RequestPolicy
    Self-Destructing Cookies
    Silent Block
    VTzilla
    WOT

    I have allowed adguard.com in both noscript and request policy, privacy badger is mainly concerned with blocking tracking cookies, and silent block only blocks what I tell it to based on regex. One thing I have just noticed is that I have the WOT addon in Firefox and also the WOT extension turned on in Adguard, so I've just deactivated WOT in Adguard to see if that makes a difference.

    If either of you need further information please don't hesitate to ask, I will do anything I can to help get this corruption problem solved.

    Kind regards.
     
  6. MC Fat Tongue

    MC Fat Tongue New Member

    Joined:
    Jan 24, 2015
    Messages:
    13
    Update:

    I have been running my computer for about 3 hours now and have had no problems so far (looks promising) here is what I have done to try and remedy my two problems:

    1. Set exclusions for Adguard in Kaspersky 2015
    2. Set exclusions for Adguard in Malwarebytes Anti-Malware
    3. Deleted the EasyPrivacy filter list from my subscriptions
    4. Allowed Adguard.com in NoScript
    5. Amended the NoScript preference (noscript.whitelistRegExp) to have a value of */adguard-ajax-api/* (as per Adguard troubleshooting guide).
    6. Allowed Aguard.com in Request Policy
    7. Disabled the WOT extension in Adguard (I already have it installed as an addon in Firefox)

    Anyway, before I implemented the seven steps above the text in my address bar in Firefox looked slightly different in that it seemed a little bit pixilated (I don't know if it's related). Now I have implemented the seven steps the text is sharp and so far I have not had any problems.

    I will keep an eye on this and report back to the forum, I wont really know if my problems are fully fix until I've done a few days of browsing to make sure. I'll report back should there be any problems or in a few days to report it fixed.

    Thank you guys for your help so far.:)
     
    Last edited by a moderator: Feb 4, 2015
  7. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,900
    @MC Fat Tongue, thank you too for such detailed information. In fact, we are able to make some amendments to the EasyPrivacy list. We'll perform some testing and if it appears that EasyPrivacy is indeed the cause, we'll find a solution.

    I will keep this thread updated.
     
  8. MC Fat Tongue

    MC Fat Tongue New Member

    Joined:
    Jan 24, 2015
    Messages:
    13
    Hello I'm reporting back as promised.

    I've not had any more problems since implementing the seven steps (post #6). I have also added back the EasyPrivacy filter list and everything seems to be working fine now.

    Vasily, I am very grateful for your help with this matter. From my own experience and reading other posts here, I'm impressed with the way in which the Adguard team deal with user problems and requests, I only wish all other software company's dealt with their customers in the same way.:D

    Thank you.
    Kind regards.
     
    Last edited by a moderator: Feb 6, 2015
  9. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,900
    Thank you too! Both for kind words and forum activity. I'm glad everything works fine on your PC, please keep in touch if anyting goes wrong.