Firefox: Secure Connection Failed with rooted device.


New Member
Hi. I recently moved to a Pixel 5 and used the opportunity to reinstall all my apps.

The phone is successfully rooted; passing basicIntegrity and ctsProfile SafetyNet checks.

I've got device level HTTPS filtering working great by installing the AdGuard certificate in to the CA Store and then using the Move Certificate module to move it from User to System.


I then followed Method 1 from Manual installation of the security certificate into the Firefox browser.
In the past this worked perfectly. However, now I'm still getting Secure Connection Failed.


Any help in getting this working is greatly appreciated.
I know I can switch browsers (Kiwi is particularly good) but I prefer Firefox and would love to get it working again.


Boo Berry

Moderator + Beta Tester
Firefox uses its own certificate store. At the moment Firefox stable no longer allows third-party certificates to be installed anymore. Firefox beta and nightly have an about:config options to enable the system certificate store.

The only other workaround is to downgrade to Firefox 68, install the certificate into Firefox, then upgrade up to the latest Firefox stable build.


New Member
Thanks for the reply Boo Berry.

I'm actually using Firefox nightly. As mentioned above I used Method 1 in the linked article to set security.enterprise_roots.enabled to true but it no longer works.

I guess I could install FIrefox 68 and follow "Method 2" in that article to move the .cert files into the nightly build. Might give that a try later.

However, I think it's worth noting that none of the methods outlined in that article actually work anymore.


New Member

Grabbed a Firefox 68 apk and installed it on phone. From there was able to install the AdGuard certificates and run Firefox 68 without Secure Connection issues... good!

Then I followed "Method 2" and copied the cert9.db and key4.db files from the org.mozilla.firefox install to the org.mozilla.fenix install.
With high hopes I rebooted the phone for good measure and fired up a website in Firefox Nightly... Secure Connection Error!

I'm out of ideas.