Freezing internet connection

m4ch.pl

New Member
Hi everybody

Im searching for solution for many days. No luck. Problem is my Mac freezes for 1-2 minutes due to internet connection. Instant help is turn off Adguard protection or disconnect VPN (that one that is integrated in Adguard for Mac, I am not using no other VPNs). Situation is taking place on many webpages, quite often on youtube, also when I'm entering search query in status bar in Safari (freeze here is quite often, strange thus google should have best quality response). By freeze I mean Safari is stuck on loading and that all. Safari itself is responsible, also Mac is fully responsible. Just loading page freezes.
My configuration is: MacBook Air 13, Early 2014, Big Sur 11.6, Safari 15, Adguard as standalone application.
What I have checked so far:
- using Adguard as proxy (Adguard's settings, network) - not working
- installing Adguard Beta, and Nightly - not working
- it started on Catalina, so I upgraded to Big Sur - not working
- I made Big Sur clean instal, setting up Mac form scratch, manually, not using any backup or TimeMachine - not working.

I have tested some other adblockers, nothing is even close to Adguard in many angles. So any advice is appreciated. Also if you could point me out how to troubleshoot this situation would be great.

greets

Edit 1:
don't know if that is important but I use BlockBlock application (all Adguard queries that showed up during installing was accepted), also all right that Adguard asked after installing granted (I mean in Mac's Settings, Privacy)
 
Last edited:

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Hello @m4ch.pl

To troubleshoot this issue, we need to get the app logs.

Here's what we need you to do:

1. Click AdGuard icon in the menu bar --> Gear --> Advanced --> Logging level --> Debug;
2. Reproduce the issue and remember the exact time it happened;
3. Menu --> Advanced --> Export Logs and System Info...;
4. Send the archive to me at PM.
 

m4ch.pl

New Member
Hello @m4ch.pl

To troubleshoot this issue, we need to get the app logs.

Here's what we need you to do:

1. Click AdGuard icon in the menu bar --> Gear --> Advanced --> Logging level --> Debug;
2. Reproduce the issue and remember the exact time it happened;
3. Menu --> Advanced --> Export Logs and System Info...;
4. Send the archive to me at PM.
sorry for late response, thanks for being interested in help, logs sent to you thru conversation
 

m4ch.pl

New Member
Any updates on this matter and log analysis? Yes, I am aware you have a lot of work. But still for now Adguard is unusable for me. Most of time i keep it off, then everything works blazing fast. When I put protection on, every internet search is a pain, laggy :( I know my Mac is kinda old (MacBook Air 13, Early 2014) but these days I cannot afford upgrading to newer model.
Shame, I want to stay with Adguard at all costs. Other blockers are no go for me. They are not even close to what I got from Adguard in the past.
 

m4ch.pl

New Member
Im back :) By accident I've found strange issue. With Adguard shut down symptoms I described earlier are still present. Interesting. I need to do further troubleshoot. But for now it is possible my problems might not be related to Adguard. When I find something more I will post here.
 

m4ch.pl

New Member
Yeah further tests showing it is not Adguard related issue. It's kinda honest to post it here, so I'm doing it :)

For interested people, my problems with hanging search thru google, using address bar in Safari are not present when I use for example DuckDuckGO. It led me to solutions with clearing network settings. It helped. Some thrash got into my network preferences. Delete it and let macos to rebuild it from scratch seems to be right path. It helped in 95%, at least so far.

So, remember Adguard rocks :):)
 
Top