frequently failing downloads

Phonemes

Member
Hi,

I have this mainly with uploaded.net, but other cloud services might be affected as well. On uploaded.net I get these failures both with subscription and non-subscription downloads. Appears to happen only with Adguard enabled. When I close Adguard or use Admuncher instead, it never seems to happen. There is no predicting if and when a download is going to fail. Sometimes it goes wrong after a few minutes, somtimes just a few MBs before the download should finish and sometimes downloads finish without a hitch. It is extremely frustrating to have large downloads fail unexpectedly like this. Could you please look into this for me.

Latest non-beta version of Adguard. Sample download (this one just failed on me): http://uploaded.net/file/c2fu2kuh/from/tkp95p

Thank you
 

avatar

Administrator
Staff member
Administrator
Which driver version do you use in Adguard?

There is a known incompatibility between Adguard's WFP driver and F-Secure.
 

Phonemes

Member
Hi Avatar,

I am not using the WFP driver. The box under Network Settings is unticked. I just tried downloading yet another file from Uploaded, and again it is stuck at 311 of 415 MB.
 

avatar

Administrator
Staff member
Administrator
Huh, that's unexpected. One question - have you tried disabling F-Secure and Malwarebytes (just to test this)?
 

Phonemes

Member
I had a download fail with Adguard disabled today, so I'm not sure anymore that Adguard is the culprit. I'll try to download a few more files with AG disabled over the next few days to see if this was a one-off failure. I'll report back later.
 

Phonemes

Member
OK, I finally found some time to try things out. I now have reason to believe that the problem lies with Malwarebytes.

First I disabled F-Secure, with Adguard and Malwarebytes active. I downloaded some 10 large files from uploaded.net and all of them finished with no problems. (I did notice, however, that the page stalls that I often have appeared to vanish. Surfing the internet felt a lot smoother. Could this be due to the suspected incompatibility between Adguard and F-Secure?)

Then, still with Adguard active, I reenabled F-Secure and closed Malwarebytes. Again I had no problem downloading files from Uploaded.net.

Then I reenabled Malwarebytes, with both F-Secure and Adguard active, and I had two of three files fail immediately. I will run with Malwarebytes disabled for the time being, to see if this really solves the problem.

I will post a question about this in the Malwarebytes forum and come back if there is an answer.

Thank you so far
 

avatar

Administrator
Staff member
Administrator
No problem, then I'll be waiting for Malwarebytes answer.
 

Phonemes

Member
Hi Andrey,

Before going to the Malwarebytes forum, I decided to run with both Malwarebytes and F-Secure disabled for a few days, using Windows Defender to give me at least some protection. The problem with failing downloads has continued, so I have to conclude it is not related to those two programs. I am also still getting the frequent page stalls which I reported about earlier. The latter problem frequently gets so serious that I have to disable Adguard. Do you think the two problems might be related? I don't know how to troubleshoot this any further, I think a teamviewer session might be neccesary, if you could find the time for it. I downloaded the program but have not installed or used it yet, so I might need some explanation there. Or would it perhaps be better to wait for version 6 and see if that solves the problems I am experiencing?
 

avatar

Administrator
Staff member
Administrator
Is it easy to reproduce? I mean if we'll try remote access how long will we wait for this problem?
 

Phonemes

Member
No, alas, it is not. I haven't been able to find anything that triggers my download and page stall problems. All I could do is wait till the problem occurs and contact you then, but I can see this is not very convenient. How far do you think a version 6 beta is off? I prefer not to run alpha builds, but maybe we could wait for the beta and see if the problem persists there. Also, I read about your vacation, so we would probably have to wait until you get back anyway.
 

Phonemes

Member
Great, I'll be waiting for it then.

In the meantime, I have been trying the WFP network driver. Since I had disabled both F-Secure and Malwarebytes, I thought to have a go with the alternative driver and things do seem a lot better. I have been running like this (WFP with just Adguard and Windows defender running) since yesterday and none of the around 10 large downloads that I tried failed. Browsing too seems a lot snappier and I haven't had any serious page stalls. I will stay with this configuration over the next week to see if things stay like this and will report back when you get back.

Enjoy your vacation!
 

Phonemes

Member
@Andrey

I ran a few days more with the setup described in the above post and I haven't had a single failing download since. Another problem I used to have was that it often took half a minute or more before a download actually started. With the WFP driver they always start instantly. This seems strange to me, since I use Windows 7 and Firefox exclusively. The last few days I ran with this setup plus Malwarebytes in realtime and noticed no difference in performance.

I have now switched to the version 6 beta, which I run with the standard driver with no issues.
 

avatar

Administrator
Staff member
Administrator
I didn't understand, do you use TDI or WFP in v6?
It has the same option in the bottom of General settings (should be wfp by default, but better to check).
 

Phonemes

Member
In v6 I use TDI and it causes me no trouble downloading. In v5, strangely enough, switching to WFP solved my downloading problems.
I use TDI because of the incompatibility of WFP with F-Secure. Or should that be fixed in v6?
 
Last edited by a moderator:
Top