How can I make sure that business.facebook.com and all the domains that it calls are allowed?

Discussion in 'Custom Filters' started by esanchezis, Oct 19, 2017.

  1. esanchezis

    esanchezis New Member

    Joined:
    Nov 22, 2016
    Messages:
    3
    Facebook Business manager is the admin panel that I use to manage my employer's business page, review ads made by my coworkers, etc.

    Aside from it being ironic that I'm using Adguard and also manage a Facebook business page+ads, how can I make sure that I don't get the following error:

    When looking at my console I can see that the Facebook CDN is getting blocked (I removed some stuff from the URLs):

    I'd like to make sure everything gets loaded when I'm working on Facebook Business Manager, including all requests to www.facebook.com, fbcdn.net, etc. But ONLY when working on business.facebook.com.

    Is this possible? When I'm working within Business Manager, Adguard already shows it as being in the exceptions.
     
  2. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,859
    Hi
    Which AdGuard are you using?
    Please disable all filters except Eng filter, open filtering log, select checkbox `Blocked` and reproduce the issue. Then make screenshot of blocked request.
    After that you can enable your filters and check this rule in custom filter
    Code:
    @@||facebook.com/ads/$domain=business.facebook.com
    
     
  3. esanchezis

    esanchezis New Member

    Joined:
    Nov 22, 2016
    Messages:
    3
    Hi, thanks for the reply!

    I'm using Adguard Extension for Safari on macOS.

    [​IMG]

    I made the changes you suggested but it seems like it didn't make a difference. I just realized that the Facebook Ads Manager runs off of facebook.com/ads/manage/ rather than from business.facebook.com like the page manager.
     
  4. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,859
    Please try with previous rule
    Code:
    @@||fbcdn.net^$domain=business.facebook.com