How to disable injection totally


New Member
AdGuard is really good. How ever it request scripts from for every website.
Without cache, it usually takes dozens of ms or several seconds in some situation, which is really annoying.
It seems to be related with the AdGuard Assistant according to this post.
However, it still exists even if I disable the AdGuard Assistant. Moreover, it does not work even if I disable the extension option.
I wonder how can I remove this request totally. Is there a solution for that?


New Member
Hi Chinaski,
Thanks for replying,
So where can i find SafeBrowsing option? I cannot find it in Preferences. BTW, I've already disabled Stealth Mode, Security and Extensions.
Besides several filters, there is only three enabled: General - Lauch AdGuard at Login, Network - Automatically filter applications and Network - Filter Https protocol.


Support Marine
Staff member
Also, the injection can be used by processing CSS rules or when loading scripts that filter a page.